summaryrefslogtreecommitdiff
path: root/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/qingy/files/qingy-1.0.0-tinfo.patch')
-rw-r--r--sys-apps/qingy/files/qingy-1.0.0-tinfo.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch b/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
new file mode 100644
index 000000000000..f752996c92f5
--- /dev/null
+++ b/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
@@ -0,0 +1,42 @@
+Use ncurses.pc to get Libs: instead of using AC_CHECK_LIB because ncurses can be configured
+to have separate termcap library called libtinfo; and we need both -ltinfo and -lncurses for
+linking since symbols are used from both
+
+http://bugs.gentoo.org/459650
+
+--- configure.in
++++ configure.in
+@@ -125,12 +125,7 @@
+ # End compile emacs stuff
+
+ # Check for ncurses
+- HEADERS="curses.h term.h"
+- NCURSESLIB=""
+- AC_CHECK_HEADERS([$HEADERS],,[AC_MSG_ERROR([$HEADERS_ERROR_MESSAGE])],)
+- AC_CHECK_LIB(ncurses, setupterm, [NCURSESLIB="-lncurses"],[AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])] , )
+- AC_CHECK_LIB(ncurses, tputs, [NCURSESLIB="-lncurses"],[AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])] , )
+- AC_SUBST(NCURSESLIB)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [], [AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])])
+ # End check for ncurses
+
+ # Check for PAM support
+--- src/libraries/Makefile.am
++++ src/libraries/Makefile.am
+@@ -4,7 +4,7 @@
+ INCLUDES = -I../.. -I../
+ BUILT_SOURCES = parse_settings.h
+
+-AM_CFLAGS = -DSETTINGS_DIR=\"$(sysconfdir)/qingy\" -DSBINDIR=\"$(sbindir)/\"
++AM_CFLAGS = -DSETTINGS_DIR=\"$(sysconfdir)/qingy\" -DSBINDIR=\"$(sbindir)/\" $(NCURSES_CFLAGS)
+
+ if !WANT_STATIC
+ pkglib_LTLIBRARIES = libqingy.la
+@@ -35,7 +35,7 @@
+ EXTRA_libqingy_la_SOURCES = \
+ crypto_openssl.c crypto_libgcrypt.c crypto.h
+
+-libqingy_la_LIBADD = @PASSWDLIB@ @CRYPTOLIB@ @NCURSESLIB@ @XLIBS@
++libqingy_la_LIBADD = @PASSWDLIB@ @CRYPTOLIB@ @XLIBS@ $(NCURSES_LIBS)
+ libqingy_la_LDFLAGS = -release @VERSION@
+
+ libqingy_static_la_SOURCES = $(libqingy_la_SOURCES)