summaryrefslogtreecommitdiff
path: root/sys-apps/qdirstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /sys-apps/qdirstat
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest4
-rw-r--r--sys-apps/qdirstat/metadata.xml4
-rw-r--r--sys-apps/qdirstat/qdirstat-1.6.1.ebuild52
3 files changed, 57 insertions, 3 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index c080bed29ccc..b1f138294dec 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1,3 +1,5 @@
+DIST qdirstat-1.6.1.tar.gz 7708491 BLAKE2B e6a92f93c76de0f602a66409a2701cd06f1744ab67c3c829938695f1d59b7244998d3a6ddd9d6cfc6408db3ac98d355f4496348ebd198c93ea345b33414c3048 SHA512 fd4c6a3582184785d935e96e884cc3e2033e3ee174ea893816b14524c5c5c62923c5a8c5869969fb8b1d0e84bbffd9dc707a68bdb53898c55dfd14fe16946110
DIST qdirstat-1.6.tar.gz 6398935 BLAKE2B dba15df3f9dd34276ee38ccdd97d1b8158596198b22a807b4d0a68c7d33d146a25ef5b987c4a6e3dc16df421422ddc0cad2e9f60a80493ac668bcb023c15c31c SHA512 8d1350bc8995dac2de90a32ca5ddaac47a317c7e7044f39ed87a7b2e208cda0b84f04c147f7a2414d7a0c5c731479847a879aedcf5781ca772fbfa8fa360cc77
+EBUILD qdirstat-1.6.1.ebuild 890 BLAKE2B d5cfa2cb6e00b037ab1c4a4636a3762430d267679a84c136b27a0b96f8991fdd2bef3ab5f4da1877787abdc7b0f072307babf613bd990a233f79c9813951f294 SHA512 5d861861b1e133c032dacb7cae0e8a705136c118f4c25a5f2c037969de2f94f02344c301068b1c596db6c3b38fbab1c299dd9a8196883347fc9cb422ef9a0941
EBUILD qdirstat-1.6.ebuild 921 BLAKE2B 49357e923dd3fb8d9b022ea42c3aa6cb55e583caa6bd8800e1f45985e197aa144a436004974070b03757dff548dfdf6803261ecc33bea706cb4b3650ae3107d8 SHA512 a83e63e5b5102ccc790bf7098c43366aa3e6daf0d80fc435969c0157f56ad8e916885a581053d1c64d920673e1e0f06ba728be18de8744285a6efc424eb0a2ce
-MISC metadata.xml 884 BLAKE2B 933c44173db730e6bca26e358a4863cb4952c3c7795f02d5906643dbdce06d7e72a97eb6fcd8096b491b4153296d3fef72a791e3333864ca60ec80e07b7a9d2a SHA512 6816ceea9a785936cbd688f512d16270bdb0ffca89339c85a1b7616d45e83df537aaedc575c97d27e863e71f2992462efe90528444357997b923041bb0bb3853
+MISC metadata.xml 882 BLAKE2B 9ed3f6470fd94b9376ea810069b63aefae3a0347a7f46be4f1c7c17425082b4b464fc2a5e4b4246d0e6a7a0d0e88f74173593b94ef01721b85990ea59f9ad145 SHA512 606dbdffa7732dbafde3151554b62d7879de5861c0647d21876d6ce4198d63c9413256af2c380ca517e6b148f9e0ecee0c092aa6e3bb47bc972124043508edbf
diff --git a/sys-apps/qdirstat/metadata.xml b/sys-apps/qdirstat/metadata.xml
index 74e1c925919e..efe821e794ca 100644
--- a/sys-apps/qdirstat/metadata.xml
+++ b/sys-apps/qdirstat/metadata.xml
@@ -6,8 +6,8 @@
<name>Conrad Kostecki</name>
</maintainer>
<longdescription>
- Qt-based directory statistics: KDirStat without any KDE -- from
- the author of the original KDirStat.
+ Qt-based directory statistics: KDirStat without any KDE,
+ from the author of the original KDirStat.
QDirStat is a graphical application to show where your disk space
has gone and to help you to clean it up.
diff --git a/sys-apps/qdirstat/qdirstat-1.6.1.ebuild b/sys-apps/qdirstat/qdirstat-1.6.1.ebuild
new file mode 100644
index 000000000000..e4bae2ee165e
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of doc path
+ sed -e "/doc.path/s/${PN}/${PF}/" -i doc/doc.pro doc/stats/stats.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}