summaryrefslogtreecommitdiff
path: root/sys-apps/qdirstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/qdirstat
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest4
-rw-r--r--sys-apps/qdirstat/metadata.xml27
-rw-r--r--sys-apps/qdirstat/qdirstat-1.4.ebuild37
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
new file mode 100644
index 000000000000..eebab05601ab
--- /dev/null
+++ b/sys-apps/qdirstat/Manifest
@@ -0,0 +1,4 @@
+DIST qdirstat-1.4.tar.gz 2534241 SHA256 7f9a0a7304c55ebfad1e50c7747ba762b07068f48304b3d3919bdb65ee037999 SHA512 5711a78297f4224e4471ac14d8e42ee9ac746cc31315ff894dafa1db578eff4ff2a5c62edc525a49c523154a0de402f878200d96601c7924bf0273f0eac9ab74 WHIRLPOOL 4c0be459086411f649cae9d92caebe99a7bb608d6add3a5f34f2c5caa6e63b90a13e54e55c1e7f4a1c95dfc8e228c366bf4f2e2928881a9464226dbc754597cf
+EBUILD qdirstat-1.4.ebuild 750 SHA256 eacb8cdd1647466db6cd3e2af8493e19f997ed5ae31df1bf5d3d32378b39da37 SHA512 017e639e30a60f021541c547863bc2cdad0b70cb2b62981de9a2cc1a64c32a406f2b71691f0a59898d521ef128acb10d7a2e633a5bde16941711b01cf8aee75f WHIRLPOOL 48b81ef8940b5b3c029fea2bca9686e548434127f7e2a6e482912ee5fd28dea38f5894bd00b380ff6b1fb80863dc9a9facecf4d3f5686d22e1cd9371c50df29d
+MISC ChangeLog 1169 SHA256 61104f2bd818d95c94948cb137dd64e8008500dafbfcbc2284a2237667925dfc SHA512 57284bcca5300d897a36fef45bff307450ae55896a89139e39b47fe729ef05548986e0d7e752deb079eebfbfc3bbddce1698ae818c440dbeaeb559d5309a222f WHIRLPOOL 0853028cf0e68a59ca20f3db1ba03972558bc3f8dd92b7c7c87fb754969a86cb4b56f941e01fe53881c581db77cd505cc18e5e9a1d9f2557681e6bf60ee2f4d3
+MISC metadata.xml 934 SHA256 77551574e356bf1b673882d07e27d2c654296f2e25ba3ef1ea38a6160f138ed0 SHA512 8938ec964160af4bbf95642b132aa745c25124ed1f1ac12c64396ee2fa0c559033d992bdff5f1ea2c7db6a7c24a30605d43b72ce9fe2080ea6545ebe53f048c7 WHIRLPOOL 3d42c7c966472f09c7bc6837d0247f6f0640cd9b3bdef452f84694be079c013449e0d09f528c80e6cac1a478c07421804d78fdb4e3977711a0e60cc0f1e29642
diff --git a/sys-apps/qdirstat/metadata.xml b/sys-apps/qdirstat/metadata.xml
new file mode 100644
index 000000000000..dbe7f3c9c196
--- /dev/null
+++ b/sys-apps/qdirstat/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>j.scruggs@gmail.com</email>
+ <name>Jonathan Scruggs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Qt-based directory statistics: KDirStat without any KDE -- from
+ the author of the original KDirStat.
+
+ QDirStat is a graphical application to show where your disk space
+ has gone and to help you to clean it up.
+
+ This is a Qt-only port of the old Qt3/KDE3-based KDirStat, now
+ based on the latest Qt 5. It does not need any KDE libs or
+ infrastructure. It runs on every X11-based desktop on Linux, BSD
+ and other Unix-like systems.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">shundhammer/qdirstat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/qdirstat/qdirstat-1.4.ebuild b/sys-apps/qdirstat/qdirstat-1.4.ebuild
new file mode 100644
index 000000000000..c7c59c77ebdb
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Qt app to show where your disk space has gone and to help you clean it up"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}