summaryrefslogtreecommitdiff
path: root/sys-apps/pv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
commit5e0a5ca921524f8859808527a57655eec16efa52 (patch)
tree7c58411b1e81478df4e20082a6adec2553c24c5c /sys-apps/pv
parent4c16e0a214824f15f09396e359db4f1f5c086fec (diff)
gentoo auto-resync : 18:07:2023 - 00:58:24
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/Manifest2
-rw-r--r--sys-apps/pv/pv-1.7.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 9fa68dfb553c..3205b5da0607 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1,3 +1,5 @@
DIST pv-1.6.20.tar.bz2 115310 BLAKE2B b50623f623231e8e8615f960bad83d10e12d5274c57d23ea843d16fce30b3e690284b2d9b01f82a16b9790e2bf26f80f560e226589a62ca677a2cf90ea007691 SHA512 e445f91b298ed285ddab54a3f8a6b5d5297e2e2eb8ad7b2ee2cbacca4adda9c6ca2bf3c77bf2a93373d3875c5b3b0b345d3945cbd91fc2647c6c25f1661a6752
+DIST pv-1.7.0.tar.bz2 115665 BLAKE2B efdd0434d23fe1ed008224fe0fe5182684010a78650284e920b2cd93134f08e63172df0279b8a4b2c2c4dceb9dbdaa209e402394fb1c4c431d991225f579f718 SHA512 b90ddaa1f950b1b300f1721e5ab8bc2c7a0c46491e439ce33c7b74fd4525e730a99c218a874b3dae2dc3a8a5e0eb5c5add51f7c8be48d0c3d8f135df44779af8
EBUILD pv-1.6.20.ebuild 1456 BLAKE2B 055fc1d118f5f5500e3fb453d94ae40c0db8389425df249cd2cc8d9303db9a113a13d324c1b2f53d993ce455eaaaa695bc542a4c53f5bc2564d314ffbe76721d SHA512 583e35041a54b3123c757acad234afb053d00703e8b8a57efb680fc76d7738485f30d0aed94ad31bbd9d4a4db7356b72a0628ec74fffaa3388af8b7e3abf54a3
+EBUILD pv-1.7.0.ebuild 1597 BLAKE2B 59992824f88bf9301d94434d9e00b715ab2b4f02e9b185873cf6ade7b3e2734a3c57ea4b26c0eb3dc6e3bacb15158d2e79a31ef38f813b28c6a197ae29247165 SHA512 a6af96cc2f820081221ec2ab2923b2c1cd84a3fd9ed29999cfc104501be813ac52c14a361b25ae4c0ba8b1caaa9d9f2ffb39ae426de9ec82e5c6c6036e3ce667
MISC metadata.xml 483 BLAKE2B c6240298c7a79c7d5839c593b0139c990477ce67aeb92b585bbb09a07d51bbe9bd75aaeac678ddd81c05cc6f9e36860ad8cfc889204e835019f854477a5bc7bf SHA512 082cac9d7bcff373929e3c0a7af524b65c48cc427755232f981ccd4947466f2f3325a75f691f1bf79e74eebde3e53b4ebd4c904b40affc0d7fbd243f8ab36605
diff --git a/sys-apps/pv/pv-1.7.0.ebuild b/sys-apps/pv/pv-1.7.0.ebuild
new file mode 100644
index 000000000000..d13550cbb754
--- /dev/null
+++ b/sys-apps/pv/pv-1.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de fr pl pt"
+PLOCALE_BACKUP="en"
+inherit flag-o-matic linux-info toolchain-funcs plocale
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml"
+SRC_URI="https://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls"
+
+DOCS=( README.md doc/NEWS.md doc/TODO.md )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # See https://github.com/a-j-wood/pv/issues/69
+)
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+
+ disable_locale() {
+ local locale=${1}
+ sed -i configure -e "/ALL_LINGUAS=/s:${locale}::g" || die
+ }
+
+ plocale_find_changes src/nls '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+}
+
+src_configure() {
+ tc-export AR
+
+ # Workaround for https://github.com/a-j-wood/pv/issues/69
+ append-lfs-flags
+
+ econf \
+ --enable-lfs \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}