summaryrefslogtreecommitdiff
path: root/sys-apps/portage/portage-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sys-apps/portage/portage-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sys-apps/portage/portage-9999.ebuild')
-rw-r--r--sys-apps/portage/portage-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index f5da3ae281b4..4c546564cf0c 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( pypy3 python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
PYTHON_REQ_USE='bzip2(+),threads(+)'
inherit distutils-r1 git-r3 linux-info systemd prefix
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="apidoc binpkg-zstd build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
>=app-arch/tar-1.27
@@ -32,6 +32,7 @@ DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
# app-portage/gemato goes without PYTHON_USEDEP since we're calling
# the executable.
RDEPEND="
+ app-arch/zstd
>=app-arch/tar-1.27
dev-lang/python-exec:2
!build? (
@@ -53,7 +54,6 @@ RDEPEND="
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
) )
- binpkg-zstd? ( app-arch/zstd )
!<app-admin/logrotate-3.8.0"
PDEPEND="
!build? (
@@ -115,12 +115,6 @@ python_prepare_all() {
|| die "failed to append to make.globals"
fi
- if use binpkg-zstd ; then
- einfo "Adding BINGPKG_COMPRESS=\"zstd\" to make.globals ..."
- echo -e '\nBINGPKG_COMPRESS="zstd"' >> cnf/make.globals \
- || die "failed to append to make.globals"
- fi
-
if use build || ! use rsync-verify; then
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
-i cnf/repos.conf || die "sed failed"
@@ -238,6 +232,10 @@ pkg_preinst() {
PYTHONPATH="${D%/}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
"${PYTHON}" -m portage._compat_upgrade.default_locations || die
+ env -u BINPKG_COMPRESS \
+ PYTHONPATH="${D%/}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
+
# elog dir must exist to avoid logrotate error for bug #415911.
# This code runs in preinst in order to bypass the mapping of
# portage:portage to root:root which happens after src_install.