summaryrefslogtreecommitdiff
path: root/sys-apps/portage/portage-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /sys-apps/portage/portage-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'sys-apps/portage/portage-9999.ebuild')
-rw-r--r--sys-apps/portage/portage-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index b1da4eee48b8..a483b5524449 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ PYTHON_COMPAT=(
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 git-r3 systemd
+inherit distutils-r1 git-r3 linux-info systemd
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -86,6 +86,12 @@ prefix_src_archives() {
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git
https://github.com/gentoo/portage.git"
+pkg_pretend() {
+ local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"
+
+ check_extra_config
+}
+
pkg_setup() {
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
}