summaryrefslogtreecommitdiff
path: root/sys-apps/portage/portage-2.3.79.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-apps/portage/portage-2.3.79.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-apps/portage/portage-2.3.79.ebuild')
-rw-r--r--sys-apps/portage/portage-2.3.79.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-2.3.79.ebuild b/sys-apps/portage/portage-2.3.79.ebuild
index 8e7b92e07cce..42d64562857c 100644
--- a/sys-apps/portage/portage-2.3.79.ebuild
+++ b/sys-apps/portage/portage-2.3.79.ebuild
@@ -3,9 +3,10 @@
EAPI=5
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=(
pypy
- python3_5 python3_6 python3_7
+ python3_5 python3_6 python3_7 python3_8
python2_7
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
@@ -16,7 +17,7 @@ DESCRIPTION="Portage is the package management and distribution system for Gento
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
SLOT="0"
IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
@@ -258,4 +259,14 @@ pkg_preinst() {
if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
fi
+
+ if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+ elog "The emerge --autounmask option is now disabled by default, except for"
+ elog "portions of behavior which are controlled by the --autounmask-use and"
+ elog "--autounmask-license options. For backward compatibility, previous"
+ elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+ elog "Users can get the old behavior simply by adding --autounmask to the"
+ elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+ elog "change, see https://bugs.gentoo.org/658648."
+ fi
}