summaryrefslogtreecommitdiff
path: root/sys-apps/pnputils/pnputils-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-apps/pnputils/pnputils-0.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-apps/pnputils/pnputils-0.1.ebuild')
-rw-r--r--sys-apps/pnputils/pnputils-0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/pnputils/pnputils-0.1.ebuild b/sys-apps/pnputils/pnputils-0.1.ebuild
new file mode 100644
index 000000000000..23a40d5a8fa6
--- /dev/null
+++ b/sys-apps/pnputils/pnputils-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Plug and Play BIOS utilities"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://archive.debian.org/debian/pool/main/p/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}
+
+src_install () {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}