summaryrefslogtreecommitdiff
path: root/sys-apps/pnputils/pnputils-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-apps/pnputils/pnputils-0.1-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-apps/pnputils/pnputils-0.1-r1.ebuild')
-rw-r--r--sys-apps/pnputils/pnputils-0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/pnputils/pnputils-0.1-r1.ebuild b/sys-apps/pnputils/pnputils-0.1-r1.ebuild
new file mode 100644
index 000000000000..57de733ddcdd
--- /dev/null
+++ b/sys-apps/pnputils/pnputils-0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Plug and Play BIOS utilities"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://archive.debian.org/debian/pool/main/p/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-musl.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}