summaryrefslogtreecommitdiff
path: root/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild')
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
index 52df8b15b9ff..7df482af2a2e 100644
--- a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils bash-completion-r1
+EAPI=7
+inherit bash-completion-r1
DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
HOMEPAGE="https://launchpad.net/pmount"
SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV/_/-}.orig.tar.bz2"
+S=${WORKDIR}/${P/_/-}
LICENSE="GPL-2"
SLOT="0"
@@ -21,21 +22,22 @@ DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext"
-S=${WORKDIR}/${P/_/-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch
+ "${FILESDIR}"/${P}-locale-regex.patch
+)
src_prepare() {
# Restore default value from pmount <= 0.9.23 wrt #393633
sed -i -e '/^not_physically_logged_allow/s:=.*:= yes:' etc/pmount.conf || die
- cat <<-EOF > po/POTFILES.skip
+ cat <<-EOF > po/POTFILES.skip || die
src/conffile.c
src/configuration.c
src/loop.c
EOF
- epatch \
- "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch \
- "${FILESDIR}"/${P}-locale-regex.patch
+ default
}
src_configure() {
@@ -45,14 +47,15 @@ src_configure() {
src_test() {
local testdir=${S}/tests/check_fstab
- ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
- ln -s $testdir/c $testdir/e \
- || die "Unable to create fake symlinks required for testsuite"
+ ln -s a "${testdir}/b" &&
+ ln -s d "${testdir}/c" &&
+ ln -s c "${testdir}/e" ||
+ die "Unable to create fake symlinks required for testsuite"
emake check
}
-src_install () {
+src_install() {
# Must be run SETUID+SETGID, bug #250106
exeinto /usr/bin
exeopts -m 6710 -g plugdev