summaryrefslogtreecommitdiff
path: root/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild')
-rw-r--r--sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild b/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
new file mode 100644
index 000000000000..e43bb34fb1ae
--- /dev/null
+++ b/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [ ${PV} = 9999* ]; then
+ EGIT_REPO_URI="git://git.tdb.fi/pmount-gui"
+ inherit git-2
+else
+ SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple graphical frontend for pmount"
+HOMEPAGE="http://git.tdb.fi/?p=pmount-gui.git;a=summary"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/pmount
+ virtual/udev"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.txt
+}