summaryrefslogtreecommitdiff
path: root/sys-apps/plocate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
commit5d0c50eb490582cf1277e150ee5bb63a90b85aa6 (patch)
tree7204c80f526d36b5a4c7c6cd1339971b97636808 /sys-apps/plocate
parent13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (diff)
gentoo auto-resync : 22:11:2022 - 13:06:24
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest2
-rw-r--r--sys-apps/plocate/plocate-1.1.17.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index 3187492dfadf..0a8fa59d269d 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -5,5 +5,7 @@ AUX plocate-cron.conf 237 BLAKE2B 531d6461309b520db31ab8f682ebbe56f2cd425222ebbc
AUX plocate.cron 1392 BLAKE2B 89f7eb05879c0c1a6c30376d36dc469dde0b94df3758ae659012cf9fb6e9fb2783a0d8e53ea5f79d99e2f00be72ef24a254f2d91038a30dc9e19cd2b250782f9 SHA512 b15583e98e253c2fcb658bd9c1c589bacddb8b033eb565333d9f990b1fd320fcfbe1d950657c8b5823d4cb034ccad369bdd2178ef955e42aa9c2f8e8a0268b3f
AUX updatedb.conf 898 BLAKE2B de832ebc92e103ccaf8923b2eb872ad8e1ef36be2dfaa463a054e3e9fc256102db676ab0568501b695d943fcb74ae6ab01585bf7301cc6aa9ce6d709cc1690b5 SHA512 8b0b32e949636aef46c5439b0c963cc113306cedb1e5c84dbbfa2efba6562ca6dd602fdbfa0b3bc9095b0cf30a619ebb366535406cdb461f20d012ec1af7ff9d
DIST plocate-1.1.16.tar.gz 73397 BLAKE2B b6706145e9cba8b386761229cfbf23f8a9490596210b0a8dc467dfa6a6ed5b349c8f84cfcbe0430e89691afb50e257a3d331b1dcdc638611407587c8b623e72b SHA512 01dfc3ba434e6164f3e582fb102bd7ec0167a8f93e4cf9c3e72af804a8eda9b69b04fec20ee34fc19549d810b97076342f3a83b46705d0311ada6004d05da26c
+DIST plocate-1.1.17.tar.gz 73528 BLAKE2B b5694c3669a9717a9410093b1fba2eef029550989ffcbf9b6e7b48cc715c215b909c140cd98d47d30d31ccb6e04fd54e9b565bc8e16c1d9901ccf82a906de311 SHA512 36fa7ad01b5136ce75aad56d154cac511f2f4952a52ef2f16143e46b65a8b129e9011dbdd66d80a0288ef15291864cef0e51d26181b966a2f67b5e4f9fc42c7d
EBUILD plocate-1.1.16.ebuild 2316 BLAKE2B a139caa087043bd224f577cc0e1066adefd863c364b54cdd1df10a92fb601049ab6ce1111b2c887cf91fc43b7832e46ca88dcb4faae525052fe4d459a429ea81 SHA512 5c0c49b974ab304754724f3bba87180ddc59c1dc6ee3cd408278d53adf6fb77f5fbe87a4a0a85c6f75a504ec12a986d1f005724bfbfb0d8594e664bd4ef46003
+EBUILD plocate-1.1.17.ebuild 2196 BLAKE2B 6bfa71bdf894128662b3a7e3b5275bf52235e36cb78f05a4e3c705d2e438f958c77cbdbf0eb58c93aa03977c970d5decc44fc3c2c05ad970a12b2449875ecb25 SHA512 aff722542605c034f38718750f1112d3e0533745d5ea4d07afdd21e2a441d4bcabee3190835ec8087e40a2f05125da37892dd73278f6bff6c9d90821f6674923
MISC metadata.xml 1437 BLAKE2B d3aece3d36e8cc4ceaf9947f0b535c7e2187a25cbb88910f704b1d72a2784831bfb746cca323c98183964688e6b5f2f2fa6bf54c97f8fc99eeea4ee946983e0d SHA512 b24d79da1b27531a7f3353128f7fbc583ef064f4aff58894e9d37dfa9144203c1f1898113aa31f82604aea93de66423e3313924bad25e31e075832c77a99c39e
diff --git a/sys-apps/plocate/plocate-1.1.17.ebuild b/sys-apps/plocate/plocate-1.1.17.ebuild
new file mode 100644
index 000000000000..3a4eeb26aae2
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.17.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.15-meson-use-feature-option-for-libiouring.patch
+)
+
+pkg_setup() {
+ if use io-uring && linux_config_exists; then
+ if ! linux_chkconfig_present IO_URING; then
+ ewarn "CONFIG_IO_URING must be enabled for USE=io-uring"
+ fi
+ fi
+}
+
+src_prepare() {
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ -Dinstall_systemd=true
+ -Dinstall_cron=false
+ -Dsystemunitdir="$(systemd_get_systemunitdir)"
+ "$(meson_feature io-uring use_libiouring)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}