summaryrefslogtreecommitdiff
path: root/sys-apps/plocate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
commit4eaeaf683cb193978f14d55e52ea834d32e8a089 (patch)
treecd23a4d91c322f29e5c001bc033a008e309831a4 /sys-apps/plocate
parente12724a13a1677867978f5ecd7fabda4eb1e3aa8 (diff)
gentoo auto-resync : 02:01:2024 - 14:53:28
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest2
-rw-r--r--sys-apps/plocate/plocate-1.1.20.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index ba27505f738d..be2cb6aaf005 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -3,5 +3,7 @@ AUX plocate-cron.conf 237 BLAKE2B 531d6461309b520db31ab8f682ebbe56f2cd425222ebbc
AUX plocate.cron 1392 BLAKE2B 89f7eb05879c0c1a6c30376d36dc469dde0b94df3758ae659012cf9fb6e9fb2783a0d8e53ea5f79d99e2f00be72ef24a254f2d91038a30dc9e19cd2b250782f9 SHA512 b15583e98e253c2fcb658bd9c1c589bacddb8b033eb565333d9f990b1fd320fcfbe1d950657c8b5823d4cb034ccad369bdd2178ef955e42aa9c2f8e8a0268b3f
AUX updatedb.conf 898 BLAKE2B de832ebc92e103ccaf8923b2eb872ad8e1ef36be2dfaa463a054e3e9fc256102db676ab0568501b695d943fcb74ae6ab01585bf7301cc6aa9ce6d709cc1690b5 SHA512 8b0b32e949636aef46c5439b0c963cc113306cedb1e5c84dbbfa2efba6562ca6dd602fdbfa0b3bc9095b0cf30a619ebb366535406cdb461f20d012ec1af7ff9d
DIST plocate-1.1.19.tar.gz 73964 BLAKE2B bf488c124b219822c0b426f57f3389f2611395abb7ddd22c72c51086480af1811ab2ed5f2a96cb6ad7d769be7dd60c3482de46841f2d5be85abdc1a1ce586ee8 SHA512 7bbbe914dbab75adb7f38302b7a06cfbb7c18b0e580892dced89d72dc0076e98a75482833b76200bb68b99a0a6093639967b962d0b69be526360995f7d833fcd
+DIST plocate-1.1.20.tar.gz 74409 BLAKE2B 4ac6edb5b347c03adb23bb1dc7549647829d5620d17994ee1cf66a46b78b20dca546c726e8161b339b65b97cf2983564723ad218f25f4ef57e58fd0cbe9db76a SHA512 511a25f7e1dba3e9ea836dc3b462cf3b1aa3c111819531fad73857bc0fd22fcbc387715a8981ef58be31103b6ac802468eb18b32826dc220a6781ebf83b1c153
EBUILD plocate-1.1.19.ebuild 2195 BLAKE2B 6045f01f6e2962f8ee370f92fdb08e6bfdbf907ba5ce5f69c0f98da7e1f68f3ba939d4762bc42591123b018e6c732899b2c4e720e6b0fdcc6cc07c3a45b9d1b7 SHA512 e81c40738feb7c704825c6b497f923cfff9089610eb94384b9a91011dce92647d0ea1612ee691ea67ad4b1f97b7acb116e8526d9aa2bc02ae9e5f9701778c681
+EBUILD plocate-1.1.20.ebuild 2196 BLAKE2B 9b56e8ab67e1ab12c3d01330053b08c01ac95047b804bea983d2d45fde3a36dcd3d763624735f1ecde1f386e4c9cc5766f4f64d4d8f3f4cf7b0cffea41547454 SHA512 23984369b1521eb1aa58c7566dbf3ed8e965e626d10f291daab36cbb6d0008ff913a7ea8ca2fa1f2f2ec1cc5f75b4797cc90958fa6d0bbcb2e0f723751b36467
MISC metadata.xml 1424 BLAKE2B c0120cd8ebfe537535ef4c9d1c0af50782a8f70f5be649ea732d7196fa7c04cb3cd5eb88635ad1d8296a16ff0eaacce402024f3dd921b1b0d0aa5512f4ffe692 SHA512 633c882489bd93a3c5f1fce385e7957589e99e58185ff751fe2f0e06a49a82f6cafc9a0b490a7dbb3a3761d24904f9e360b53369b341cb65b2a58dac28e5d0e8
diff --git a/sys-apps/plocate/plocate-1.1.20.ebuild b/sys-apps/plocate/plocate-1.1.20.ebuild
new file mode 100644
index 000000000000..cfb1c096e464
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.20.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.15-meson-use-feature-option-for-libiouring.patch
+)
+
+pkg_setup() {
+ if use io-uring && linux_config_exists; then
+ if ! linux_chkconfig_present IO_URING; then
+ ewarn "CONFIG_IO_URING must be enabled for USE=io-uring"
+ fi
+ fi
+}
+
+src_prepare() {
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ -Dinstall_systemd=true
+ -Dinstall_cron=false
+ -Dsystemunitdir="$(systemd_get_systemunitdir)"
+ "$(meson_feature io-uring use_libiouring)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}