summaryrefslogtreecommitdiff
path: root/sys-apps/plocate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-apps/plocate
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest2
-rw-r--r--sys-apps/plocate/plocate-1.1.6.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index 820b84039893..d2b7e3a7cbcc 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -3,5 +3,7 @@ AUX plocate-cron.conf 237 BLAKE2B 531d6461309b520db31ab8f682ebbe56f2cd425222ebbc
AUX plocate.cron 1392 BLAKE2B 89f7eb05879c0c1a6c30376d36dc469dde0b94df3758ae659012cf9fb6e9fb2783a0d8e53ea5f79d99e2f00be72ef24a254f2d91038a30dc9e19cd2b250782f9 SHA512 b15583e98e253c2fcb658bd9c1c589bacddb8b033eb565333d9f990b1fd320fcfbe1d950657c8b5823d4cb034ccad369bdd2178ef955e42aa9c2f8e8a0268b3f
AUX updatedb.conf 898 BLAKE2B de832ebc92e103ccaf8923b2eb872ad8e1ef36be2dfaa463a054e3e9fc256102db676ab0568501b695d943fcb74ae6ab01585bf7301cc6aa9ce6d709cc1690b5 SHA512 8b0b32e949636aef46c5439b0c963cc113306cedb1e5c84dbbfa2efba6562ca6dd602fdbfa0b3bc9095b0cf30a619ebb366535406cdb461f20d012ec1af7ff9d
DIST plocate-1.1.5.tar.gz 69090 BLAKE2B 70b398eb1a5d7b36294188966ef5f46843d9db9f41021a294d88795944412b4ef3819771082955a74a9945296fa14c59461a4ab4af197691f7085a40eeb7f0ef SHA512 6169ea7b3587e12e555a42e0c70e149626810f5e6f9f1f03ca1b069d7892d45bc52cabf072324eaa6f14055943dd680a71642914c0218a770e2b00a22c75efbc
+DIST plocate-1.1.6.tar.gz 71518 BLAKE2B 497ff8061e3e880e2502cb3fd13e3c9de06e8c4fffdc6b405e1a9a4e33f694b86f2e32fee93f57f5dd122b52a4a8615f1615ee77c6519448afcc596210aced65 SHA512 d94104b774ad75f60b8de2c044ac203ed28ffd6a0765818cf3e9d50d589d0c53cefbe77510d650c221e2c36b8672f63cd45ccb2f8774b20f9cb4d51de0bb4dbe
EBUILD plocate-1.1.5.ebuild 1857 BLAKE2B b90e979dd6f7771a0ef4c481e0563f59208f35ab1032b61a3c9a1998dd987cd5793ab0d6d80110822c85abcbcc117ff12d5a613025e8185d1ec3f09c9aef341e SHA512 ed35405d72cc84b4c5469a681dc03869054ca6ea9b7a8155001b2d13361536375a9985c28caddf689d840ec24f2a497363957be9f9b7e15317531656943d2758
+EBUILD plocate-1.1.6.ebuild 1857 BLAKE2B b90e979dd6f7771a0ef4c481e0563f59208f35ab1032b61a3c9a1998dd987cd5793ab0d6d80110822c85abcbcc117ff12d5a613025e8185d1ec3f09c9aef341e SHA512 ed35405d72cc84b4c5469a681dc03869054ca6ea9b7a8155001b2d13361536375a9985c28caddf689d840ec24f2a497363957be9f9b7e15317531656943d2758
MISC metadata.xml 1285 BLAKE2B 778c722e0b5e673f97f22f3c60fb2ed5cd1ce18ceb6aec3426049010eaa930a51bb68c2bda2b9a3f471a9737dec406c52fc849cb674df913410868d3c9dd5479 SHA512 f558b515d2dabb31d11ace480ad94c8c2a925c5ffab618930bb3fecc29fb710f7ad3ff253955272930004ca96344950ce5aa743bece0862a3a6c1c1675be22ff
diff --git a/sys-apps/plocate/plocate-1.1.6.ebuild b/sys-apps/plocate/plocate-1.1.6.ebuild
new file mode 100644
index 000000000000..4aaa46baf9c4
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~IO_URING"
+ERROR_IO_URING="required for USE=io-uring"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.5-no-systemd-check.patch
+)
+
+src_prepare() {
+ # Pretend liburing dep doesn't exist when USE flag off
+ if ! use io-uring; then
+ sed -i "s/dependency('liburing/dependency('/" meson.build || die
+ fi
+
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}"/plocate.cron plocate
+ fperms 0755 /etc/cron.daily/plocate
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}