summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-apps/pkgcore/pkgcore-9999.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-9999.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 28296ac77537..34a210caba47 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -21,25 +21,24 @@ LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
IUSE="doc test"
-if [[ ${PV} == *9999 ]] ; then
- SPHINX="dev-python/sphinx[${PYTHON_USEDEP}]"
-else
- SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-fi
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
- RDEPEND+=" =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
RDEPEND+=" >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
- ${SPHINX}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
python_compile_all() {
- esetup.py build_man $(usex doc "build_docs" "")
+ local esetup_args=( $(usex doc "--enable-html-docs" "") )
+ # only build man pages for live ebuilds if doc USE flag is enabled
+ [[ ${PV} == *9999 ]] && esetup_args+=( $(usex doc "--enable-man-pages" "") )
+ esetup.py build "${esetup_args[@]}"
}
python_test() {
@@ -47,8 +46,9 @@ python_test() {
}
python_install_all() {
- distutils-r1_python_install install_man \
- $(usex doc "install_docs --path="${ED%/}"/usr/share/doc/${PF}/html" "")
+ esetup.py install_docs \
+ --docdir="${ED%/}/usr/share/doc/${PF}" \
+ --mandir="${ED%/}/usr/share/man"
distutils-r1_python_install_all
}