summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-apps/pkgcore/pkgcore-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-9999.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 670df92a2cf7..09021519bb70 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -19,35 +19,26 @@ HOMEPAGE="https://github.com/pkgcore/pkgcore"
LICENSE="BSD MIT"
SLOT="0"
-IUSE="doc test"
+IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND+=" >=dev-python/snakeoil-0.8.3[${PYTHON_USEDEP}]"
+ RDEPEND+=" >=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-python_compile_all() {
- local esetup_args=( $(usex doc "--enable-html-docs" "") )
- # only build man pages for live ebuilds if doc USE flag is enabled
- [[ ${PV} == *9999 ]] && esetup_args+=( $(usex doc "--enable-man-pages" "") )
- esetup.py build "${esetup_args[@]}"
-}
-
python_test() {
esetup.py test
}
python_install_all() {
- esetup.py install_docs \
- --docdir="${ED%/}/usr/share/doc/${PF}" \
- --mandir="${ED%/}/usr/share/man"
+ local DOCS=( AUTHORS NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
distutils-r1_python_install_all
}