summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
commit1cfea2a84c51291a77ab820b6871efcff10c148d (patch)
tree924f8b07cb24ba72b3d889cf4b50bdff4d2785c0 /sys-apps/pkgcore/pkgcore-9999.ebuild
parent441369caa3d11703d0349d4b9746b7ad10aa6cb2 (diff)
gentoo auto-resync : 07:11:2022 - 21:22:53
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-9999.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 86ca28dcedd6..ad37b266d812 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=standalone
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -32,31 +32,27 @@ else
RDEPEND+=" >=dev-python/snakeoil-0.10.1[${PYTHON_USEDEP}]"
fi
BDEPEND="
+ >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
test? (
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
dev-vcs/git
)
"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fail because of forcing Gentoo's prefix
+ tests/ebuild/test_eapi.py::TestEAPI::test_register
+ tests/ebuild/test_eapi.py::TestEAPI::test_is_supported
+)
src_prepare() {
# force Gentoo's prefix
- sed -e "/INSTALL_PREFIX =/s@= .*\$@= '${EPREFIX}/usr'@" -i setup.py || die
+ sed -e "/INSTALL_PREFIX =/s@= .*\$@= '${EPREFIX}/usr'@" -i py_build.py || die
distutils-r1_src_prepare
}
-src_test() {
- # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
- # https://bugs.gentoo.org/840266
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict /
-
- local -x PYTHONDONTWRITEBYTECODE=
- distutils-r1_src_test
-}
-
python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*