summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild b/sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild
new file mode 100644
index 000000000000..cb4367497c7a
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.11.8-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pkgcore-0.10.18-sighdlr-r1.patch"
+)
+
+distutils_enable_tests setup.py
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}