summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 04:55:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 04:55:37 +0000
commite984f0bb49fed14c51c7c15ed8d7b8bd2cca4b1d (patch)
tree99c30d1c04aa29f440b825a7bf68be3c8f9e75d1 /sys-apps/pcsc-tools
parente7b6f003e8384cdfc8c0e7603329e969d8806c24 (diff)
gentoo auto-resync : 30:11:2023 - 04:55:37
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest2
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index c6ae049f65f9..1cf8df60c131 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,4 +1,6 @@
AUX smartcard.cron 319 BLAKE2B fac8c4360b802de32ff5b0fc5c2ef41aacc28186001ee6f4f3a1cd878ed75cae3f7f78aaad58580d11a695b3fd624fdd412669c743b951818de1aef6d9d4cdf0 SHA512 cb34e75090ff0fde349b81867383ed776b4c89672039f42426e27d2fce77ba0575827d2627b82fc9c435d6091b26e7c2a0e51dbcd1bdd1c883b8c37000ed516e
DIST pcsc-tools-1.6.2.tar.bz2 320182 BLAKE2B 88a76f4120a183df909ce9d189e38e51897080839ebe7ca85aa4447a441363e6917ddb1c5e6c0e881c8792078700676ad1cfe24609957a4fef54374d5be824a4 SHA512 20104baefa7928a86d21cee49d045cc35b8e74fec5be79ba5608ae046a110096efae96768d281e0f1350f71a889f89c675336d8264c75f8423369a49c03b42a8
+DIST pcsc-tools-1.7.0.tar.bz2 360064 BLAKE2B e9f22e13600e40c488720844c6e93d90e8a5dd0e085b3b5245096dbc390e5978c9ff17c9cf5c34cf82f8d0cfbaf9b3d44a25b331439c5e09bf7b075d769f7a36 SHA512 8de48526306b23e9dea6d99d29ec5f1230e3959bfe82a4d1b7d65f9767369757a1f440ceca7debeba68a8492607c91d0dcf7bec366cd213f00be45a5ef018d67
EBUILD pcsc-tools-1.6.2.ebuild 1343 BLAKE2B f2f7843d68c78d5d44ef49eac125f5c3484f92136d1ebad7462e0b2be1aea6a7c5debcf0309dfe0e50eb12ab8d94ccdfcd4159146f0257b7d585c927077b8d6e SHA512 761a3bd17e109df415ee556205d110dacf00f2fbec4cfbfd2df0eda03d7b865bc6c5c6f15a0a4dfa37c9f4afffd4f2837bf631d334317bfdf7b6f75734586403
+EBUILD pcsc-tools-1.7.0.ebuild 1408 BLAKE2B de872673f497ade99e3f400efdc7cc3df3ec4f97dbc70c30271554f047182833f2863434d0e2a52606c67d4f3bdcf307c485a8ef35d38d205f46c24e720b1ebe SHA512 40a1eea418655d60c30bf4000ff588a8436614ece12b6cecf8f4bcd30a78ec05c098e2513d425a87c10270d8bfa25adbf6c8b4ae67d1ea0055654d1ee23c423b
MISC metadata.xml 530 BLAKE2B f9a0c7d8938d6dd2616fc62108c567ac598d880cca2e7b43f8c4c6ce53799a340a319015f2c0bae0ee8cf0a62cb5d52722d070e01d45bc38837e4e87fb0e709b SHA512 22ccf135d86a9eeb75a0b3369c5931420a88dddf679bd1de70c8c34fee5920c188931660c29d00394b40041c7ac8af0e549d90a24d2213b5a53ac5202f16c5d7
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild
new file mode 100644
index 000000000000..b7ebde02ddb1
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="https://pcsc-tools.apdu.fr/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="https://pcsc-tools.apdu.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron nls"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf $(use_enable nls gettext)
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}