summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 04:23:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 04:23:37 +0100
commitdff5148a375dbe1b3ec2c5e5e4fa482bd1224c98 (patch)
tree2048a04cc30ad174303363a25cd3cea4620b8ad7 /sys-apps/pcsc-tools
parentcb259c03daeefbbc0a46d61314d25be7edeb14e8 (diff)
gentoo auto-resync : 05:09:2022 - 04:23:36
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest2
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 213b6914bf6b..1b68d156d595 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,4 +1,6 @@
AUX smartcard.cron 319 BLAKE2B fac8c4360b802de32ff5b0fc5c2ef41aacc28186001ee6f4f3a1cd878ed75cae3f7f78aaad58580d11a695b3fd624fdd412669c743b951818de1aef6d9d4cdf0 SHA512 cb34e75090ff0fde349b81867383ed776b4c89672039f42426e27d2fce77ba0575827d2627b82fc9c435d6091b26e7c2a0e51dbcd1bdd1c883b8c37000ed516e
DIST pcsc-tools-1.5.7.tar.bz2 292637 BLAKE2B f0bfa9f680a2f2b348d2baef4b4b4567008163f47d7d7e6cec694cdc424626c5c6f18c475f0e8d4c5cd49111315b3c8a934fecf30afe90bbebc0a15f8d6f4a1d SHA512 58d70f41c5815297def7d8b64807e960db85719996771ecb43a4320d3f3fc82e2deb133d9ca97b3a4e8e76267294b3339d8883ba4770bdd0071566e1ce457501
+DIST pcsc-tools-1.6.0.tar.bz2 304960 BLAKE2B a60d280d39689d7eaa407aa5857c63af0acda3791e5d9f5c2f62048260178dc728fb179aed3c369340e192ba9b3d5db04bacbe5cc6ef1519c7cde55e10ca6b45 SHA512 951014510dcfd011fc08c92a927ed8a39751c15cd9278e9bd61693a2743a82d4b88907e01e013738f6b5afb569cb4d9e9802ee575c731b83da33e92f96eb5d50
EBUILD pcsc-tools-1.5.7-r1.ebuild 1380 BLAKE2B 8b965aea287ba16e74f2dc1fa3a2fef992ea8f688c7eab2fac5cd0e875cad7e0627d6e3ba83dbebb9ca6b6c9fd62cbf5c30b13a5952a9ad82978d6f05ada54b7 SHA512 0632d67332bdf81fdc647bbe4dd2f5ca6fb16de9ec7d9539ca3126a211504769f2f15ca31092e447a3cade72d2d745a90d088ef0601071a6357a03a2f21ff1d8
+EBUILD pcsc-tools-1.6.0.ebuild 1387 BLAKE2B 541eb3552bb12c1851c488cd0ed354a1d9d3754d42c0253c4865cf22a08c2ec393f44ad7089574b0a0d8461288c89d5c817f19c37ae79b15734a2d4f578284f8 SHA512 018994f252681c21aed94d66a1327f672e21475b0218799c692dca5f915bdcff3749760e70be466ba3470044be56a70d450668c513ad90fef5e6144d70d18282
MISC metadata.xml 357 BLAKE2B f11eef0c97a68d73891f21b1d47bf3e5cca15e4e0f7085c64c8d6b8319c87547d58b5b08b82adb8dbe1537fd93095a139ec3eab37ac58254552ceb4d1f16b149 SHA512 62145d52ad3ec0d9f99e356bf9a22537d62a84064a1cdf12d22504a678af3a7282193b91ba9061fe3e2332d3d693402cef7703a3e40280bf3453cfdbe38b5889
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
new file mode 100644
index 000000000000..76cab41d9392
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}