summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /sys-apps/pcsc-tools
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest2
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 4f688e1dcf9f..d313e9dc12e0 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,4 +1,6 @@
AUX smartcard.cron 319 BLAKE2B fac8c4360b802de32ff5b0fc5c2ef41aacc28186001ee6f4f3a1cd878ed75cae3f7f78aaad58580d11a695b3fd624fdd412669c743b951818de1aef6d9d4cdf0 SHA512 cb34e75090ff0fde349b81867383ed776b4c89672039f42426e27d2fce77ba0575827d2627b82fc9c435d6091b26e7c2a0e51dbcd1bdd1c883b8c37000ed516e
DIST pcsc-tools-1.4.27.tar.gz 192342 BLAKE2B c17fa151afd6064bc15dda156248799bffaa08118b65fe57690a7a6e4697e0f44c31abc7e1b03f3eb6a3c551bec86b853b944b693f5b9242d649563fb64a2cd4 SHA512 f4532e6deab799c96fb344a8b3d07768b4c13d8800a486cf0bfe6200794e2b49dcd1c761dec86dca3c350d88577ec2bba420298c693449fddeeff93672449836
+DIST pcsc-tools-1.5.3.tar.bz2 267564 BLAKE2B b060e6fc923c6274d38c364325c367f793acf2979f2410c92857cce7483ebbb59db07657bc27be6d5a799f7f85da45782c4f1a9bbf7c450b43d533dce54755e7 SHA512 da5b362b7a3a6d47dd309ff217e6dd8af29298501db5e898ecd68762020ce62fc982132205f9bbee159a7d7eac549fdb8f25395416bb52bc0d0c888a5b0fa1a0
EBUILD pcsc-tools-1.4.27.ebuild 1443 BLAKE2B fa74ae4845511bddc3b792be953ab9b3b6aad6299e3600969346a9d4a8f97c3ab77c0d02973ad29dd6ee825196f7f2b8453f71f28f9acfd966781b8c3dcbfcae SHA512 4f2c67271f3e343469e0d556980a760e376c143a35763ab740885ef154728d8416f8e36beeda24b924bad5986c814cb1604eef6301b1f1d0982ca2909d1a4d35
+EBUILD pcsc-tools-1.5.3.ebuild 1444 BLAKE2B 1f7815bfb592f18a8fd53e5a96408318d6cd6fbcc33bae4f54aaccc94851842da9c2d68264a46ba012c1856189b9f2c94ead0535f8f7e9625307dd6fb867f840 SHA512 262046c5bee259def265853fbff55fde355a15c3ca5de7e83845920fc5403dc971880bceaa6078c57817f1a6371d19f29f84bff31dec3b099c11af3d9ed03f17
MISC metadata.xml 470 BLAKE2B b07602c76c26d4dd8468930997a52e1768a1e45aa5294a7e27995c9129f700b658a2b8afd5b73829b21620e6349cc04505a54c37166d2078a1ed250f172c2bcb SHA512 bd45fbe04b4a3e8b1501d3807f879dc1982288a10d4d209d01690e2ad1a2fbb8a475721961835717a2925e127e26135639bf6bb1f35e147595f9e8e619481079
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild
new file mode 100644
index 000000000000..216e4232f41e
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils fdo-mime multilib toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/Gtk2 )"
+
+DOCS=(
+ README Changelog
+)
+
+src_prepare() {
+ default
+ sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}