summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/pcsc-tools
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 0722da006fef..6661aef7a43f 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -2,5 +2,6 @@ AUX smartcard.cron 319 BLAKE2B fac8c4360b802de32ff5b0fc5c2ef41aacc28186001ee6f4f
DIST pcsc-tools-1.5.6.tar.bz2 289691 BLAKE2B 35dd50a3a8babff89f9e5d769ef70a573e58b2780d680c82dfa07177a3daaf527b5ccca665c901f9667ca4a81719916bd5aebb2e9b1b4d0301001498fe587832 SHA512 94076ed5af698afcec05da9645d7108c02c110fd0ee5efecbd8e0c7eb5ed9a55ee857d23b79ab2ccb93847f8a36f996fa9d521d999395f63274d4bf1d9cf3d26
DIST pcsc-tools-1.5.7.tar.bz2 292637 BLAKE2B f0bfa9f680a2f2b348d2baef4b4b4567008163f47d7d7e6cec694cdc424626c5c6f18c475f0e8d4c5cd49111315b3c8a934fecf30afe90bbebc0a15f8d6f4a1d SHA512 58d70f41c5815297def7d8b64807e960db85719996771ecb43a4320d3f3fc82e2deb133d9ca97b3a4e8e76267294b3339d8883ba4770bdd0071566e1ce457501
EBUILD pcsc-tools-1.5.6.ebuild 1334 BLAKE2B 8f671f22c23efe48c28f9af575d596dd2573e97894f80f85f5727da4d62eded2779158b9f4d8d2190cda6ddce10ca26d89dbec3972870311d479127a7829096d SHA512 4692b478bfa5add8df4784e3a291bd6d782fb4c012f012d50cc964d3d726e09435a1f2257a4c9ad664fe7285a1fa33c185e1503633e43d7b35d8fe5ae25df22f
+EBUILD pcsc-tools-1.5.7-r1.ebuild 1384 BLAKE2B cfa533a949228bd37faba534b8643809fd6a3db641a3cefbfd64502769cf2c2147b04bac9245fed0e242639ebc9dc327151fde077b61fcbafa50fe8c4a102865 SHA512 6ede8d9306ef45184908398de1d87cb49da2acd5727951151b6ddce5ff9b86b6e6f60e4b023f3032d4f689bb01054a6474467840224c1862b53c9131f115f052
EBUILD pcsc-tools-1.5.7.ebuild 1384 BLAKE2B f564d094b220ae5f527e749439bf158d80ed630934ed2c67476a4e3082751be8c8db5db1686f00be9fa28f02d5e4d1219f231831b8a77178b7128516f84f3304 SHA512 8404504fabb1d89fcc85f122090ab672054efe137924faebfe496bf8eac5a30d3b1084a56b06e4b4d4d2503e9534b46a3187c092279b7263bcddf86622c8b448
MISC metadata.xml 357 BLAKE2B 42de2e205846206e147c56d469fd99d34e0e0ae207337223f93089c4d6ff86dfdeeeb65a4d0fb81398afc8d847be8f4e7559dc34ee50b899e8f20bcbea79b606 SHA512 241d96ef35852c80c581c527a9e469043c218cd81a4fa835c36d097e0b128961482d081e879cb99d74694121e35a99fb75ec7b9eba4f30970897c4e2fc3839db
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild
new file mode 100644
index 000000000000..c4fece6556bd
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.5.7-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="${DEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/Gtk3 )"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}