summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
commitfbba40085f5d1591a67b49f5aa48b4071b7560f1 (patch)
tree09e69d990e9c6d078ad475802b8728fa703bac9a /sys-apps/pcsc-lite
parent42e82780761e75f17a5cc96626558a297782f385 (diff)
gentoo auto-resync : 10:06:2023 - 21:52:51
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/Manifest2
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-2.0.0.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index 68dd5319fd6a..c36a0afbbed8 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -5,5 +5,7 @@ AUX pcscd-init.7 408 BLAKE2B 54e4995a169b7f816b0de9b409ae94a8328e792b50872d58398
AUX pcscd-udev 330 BLAKE2B 50e99953aec238fe98c6aee5219d3978b44d37c90ce74c9cb8e19b37c8677001e9b1b3701df8246bf051c6cf8b5c971f86bf1f580bfcbff270b8937328ca887d SHA512 06b672135fda9f83af4f030ff8078f8e1194ced529334c17c1a93f81ee9a5d4448bcea5ffec398f01d957a6607fbde7f69fbc23d727bb3ffad48a305cefe5c26
AUX pcscd.conf 32 BLAKE2B 2407e00c654d7e259ebf69ab420800f5605cb3ead23eb4aa07317928c38b6328eae2e566fab84c8844fb80e8a165cd32982fee753498b20c7a750f52fbb1f995 SHA512 ae27cdab8a60201639b9d9aca2d7f760146a5c5238878a0ebb562740385bf58f04bbc37a19cd1a2c8c69ee463f10beecc6531dde733cb6a6d4b06816f54b1569
DIST pcsc-lite-1.9.9.tar.bz2 789914 BLAKE2B 4a28e71e5fb23685f8ef1e0c577157708a3130e2f0eb3cb5d93c4da307d40578a862fce6726f8e4b7c6296b86f953448eb0748412d8933cc2e58a28daf285190 SHA512 748ec3d82ff48af1a8dc5a581863e5d94adc47ab8f3158ceb838c2b521ece3a746b737c7b4bb2ba8b545be85ff18b9639443864e50b2e065cf2fbfdf79ef9700
+DIST pcsc-lite-2.0.0.tar.bz2 799011 BLAKE2B d93fffebbe3daf389fcd8195c9fb3d76db64dbb98ac9c7ecd08338331389298e710ca71187cb73165868b0b5e66cb9735b60e22d508db1c1a81e04555103948a SHA512 4b34628d3269ae1859f19d2ab7eb74a76a55f3d76fbc9e4e420a081a065b1d0d7b98680552c7208f3265c684bed844afc6be1c2e5f103ad916ce7f38b52ee68c
EBUILD pcsc-lite-1.9.9.ebuild 3335 BLAKE2B f16cd542eecf6d5987c0f74d337fefda3f38e4c24fdd7a395390489552af99108e91bf7f95682c08e45acf2254d87f77cf70b66f67115e9da80fa648bd86b238 SHA512 5f9258b8376612e6de95d1f5e83aaebe2fdc3789da5fd1c5ba16b994e70d27f94e3c46cdc725565f89a9d78ac9ff78afa14c0d873555e0aaa01a855f2110a01d
+EBUILD pcsc-lite-2.0.0.ebuild 3342 BLAKE2B 11a56352ca501ff57be3f1ce1f0c45ca1cf2bf21ed42c39479a9de2d17b48e11233d0c573a6bb3c9762f1d2f1f77c91df24927f0c563b6570cd0b63b79542238 SHA512 d711830fe16909f1d81c281d679fee34a1e32639b2d059065797c0857ed00792225cf36395551e5a8f1104a6ccac8cbd67f0d1d777c45aabc065f2bce6e11ab4
MISC metadata.xml 1165 BLAKE2B 7574a214e85108c9507deae579da38edca6cca7fcdc20fe8295ded39067f4de37d966f96522f21aec7530e27c76d14d8490ff672f35af3601d6dbb0d33813395 SHA512 22ee7464a81a4c2d7bbf0dd9c6713f20c06aba47dd5e3f6a6e71fc3addf03636b3d17aebdc5d97926e892c01510579c19bdf7ed291720f135bdce70828ee420c
diff --git a/sys-apps/pcsc-lite/pcsc-lite-2.0.0.ebuild b/sys-apps/pcsc-lite/pcsc-lite-2.0.0.ebuild
new file mode 100644
index 000000000000..21633d5f7a05
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-2.0.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 systemd tmpfiles udev multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="https://pcsclite.apdu.fr https://github.com/LudovicRousseau/PCSC"
+SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="doc embedded libusb policykit selinux systemd +udev"
+REQUIRED_USE="^^ ( udev libusb ) ${PYTHON_REQUIRED_USE}"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+DEPEND="
+ libusb? ( virtual/libusb:1 )
+ udev? ( virtual/libudev:= )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ acct-group/openct
+ acct-group/pcscd
+ acct-user/pcscd
+ ${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-pcscd )"
+BDEPEND="
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+ "${FILESDIR}"/${PN}-1.9.8-systemd-user.patch
+)
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --disable-strict \
+ --enable-usbdropdir="${EPREFIX}"/usr/$(get_libdir)/readers/usb \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(multilib_native_use_enable doc documentation) \
+ $(multilib_native_use_enable embedded) \
+ $(multilib_native_use_enable systemd libsystemd) \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc HELP SECURITY
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+ dotmpfiles "${FILESDIR}"/pcscd.conf
+
+ if use udev; then
+ exeinto "$(get_udevdir)"
+ newexe "${FILESDIR}"/pcscd-udev pcscd.sh
+
+ insinto "$(get_udevdir)"/rules.d
+ newins "${FILESDIR}"/99-pcscd-hotplug-r1.rules 99-pcscd-hotplug.rules
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/pcsc-spy
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog
+
+ if use udev; then
+ elog "Hotplug support is provided by udev rules."
+ elog "When using OpenRC you additionally need to tell it to hotplug"
+ elog "pcscd by setting this variable in /etc/rc.conf:"
+ elog
+ elog " rc_hotplug=\"pcscd\""
+ fi
+
+ tmpfiles_process pcscd.conf
+
+ use udev && udev_reload
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}