summaryrefslogtreecommitdiff
path: root/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild')
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
index d27c8288425f..9d5b1a167818 100644
--- a/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8-r3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic linux-info toolchain-funcs udev
DEB_REV=${PV#*_p}
@@ -11,6 +12,7 @@ DESCRIPTION="PCMCIA userspace utilities for Linux"
HOMEPAGE="https://packages.qa.debian.org/pcmciautils"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
LICENSE="GPL-2"
SLOT="0"
@@ -22,13 +24,31 @@ DEPEND="${RDEPEND}
virtual/yacc
sys-devel/flex"
-S=${WORKDIR}/${PN}-${MY_PV}
+PATCHES=(
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+ "${FILESDIR}"/${P}-flex-2.6.3-fix.patch
+ "${FILESDIR}"/${PN}-018_p8-musl-unsigned-type.patch
+)
pkg_setup() {
CONFIG_CHECK="~PCMCIA"
linux-info_pkg_setup
kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
mypcmciaopts=(
STARTUP=$(usex staticsocket false true)
@@ -44,23 +64,7 @@ pkg_setup() {
STRIP=true
RANLIB="$(tc-getRANLIB)"
OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
- )
-
- use debug && append-cppflags -DDEBUG
-}
-
-PATCHES=(
- "${WORKDIR}"/debian/patches/no-modprobe-rules.patch
- "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
- "${FILESDIR}"/${P}-flex-2.6.3-fix.patch
-)
-
-src_prepare() {
- default
- sed -i \
- -e '/CFLAGS/s:-fomit-frame-pointer::' \
- -e '/dir/s:sbin:bin:g' \
- Makefile || die
+ )
}
src_compile() {