summaryrefslogtreecommitdiff
path: root/sys-apps/osinfo-db/osinfo-db-20210806.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /sys-apps/osinfo-db/osinfo-db-20210806.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'sys-apps/osinfo-db/osinfo-db-20210806.ebuild')
-rw-r--r--sys-apps/osinfo-db/osinfo-db-20210806.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db/osinfo-db-20210806.ebuild b/sys-apps/osinfo-db/osinfo-db-20210806.ebuild
new file mode 100644
index 000000000000..b76468286d57
--- /dev/null
+++ b/sys-apps/osinfo-db/osinfo-db-20210806.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="osinfo database files"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="sys-apps/osinfo-db-tools"
+
+# we don't depend on intltool here, contrary to README, as the tarball already
+# contains the processed results with translations in XML files
+
+src_unpack() { :; }
+
+src_install() {
+ osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
+}