summaryrefslogtreecommitdiff
path: root/sys-apps/openrc/openrc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/openrc/openrc-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 4c8638a6543e..c76771b7efea 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic meson pam toolchain-funcs
+inherit meson pam
DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
HOMEPAGE="https://github.com/openrc/openrc/"
@@ -13,7 +13,7 @@ if [[ ${PV} =~ ^9{4,}$ ]]; then
inherit git-r3
else
SRC_URI="https://github.com/OpenRC/openrc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="BSD-2"
@@ -25,13 +25,10 @@ COMMON_DEPEND="
pam? ( sys-libs/pam )
audit? ( sys-process/audit )
sys-process/psmisc
- !<sys-process/procps-3.3.9-r2
selinux? (
sys-apps/policycoreutils
>=sys-libs/libselinux-2.6
- )
- !<sys-apps/baselayout-2.1-r1
- !<sys-fs/udev-init-scripts-27"
+ )"
DEPEND="${COMMON_DEPEND}
virtual/os-headers
ncurses? ( virtual/pkgconfig )"
@@ -49,8 +46,6 @@ RDEPEND="${COMMON_DEPEND}
>=sec-policy/selinux-base-policy-2.20170204-r4
>=sec-policy/selinux-openrc-2.20170204-r4
)
- !<app-shells/gentoo-bashcomp-20180302
- !<app-shells/gentoo-zsh-completions-20180228
"
PDEPEND="netifrc? ( net-misc/netifrc )"
@@ -112,7 +107,7 @@ src_install() {
fi
# install documentation
- dodoc ChangeLog *.md
+ dodoc *.md
}
pkg_preinst() {
@@ -155,4 +150,15 @@ pkg_postinst() {
ewarn "without networking."
ewarn
fi
+
+ # added for 0.45 to handle seedrng/urandom switching (2022-06-07)
+ for v in ${REPLACING_VERSIONS}; do
+ [[ -x $(type rc-update) ]] || continue
+ if ver_test $v -lt 0.45; then
+ if rc-update show boot | grep -q urandom; then
+ rc-update del urandom boot
+ rc-update add seedrng boot
+ fi
+ fi
+ done
}