summaryrefslogtreecommitdiff
path: root/sys-apps/openrazer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 19:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 19:02:57 +0000
commit92f98ae772a60a2fa63efbda2f915da957a3b3b8 (patch)
treed30c4d95fdf2a9a61683de537f00ec566eef5a18 /sys-apps/openrazer
parent65c1a6f8d7210639cbdc1565ccee4758f45dfc45 (diff)
gentoo auto-resync : 20:11:2022 - 19:02:57
Diffstat (limited to 'sys-apps/openrazer')
-rw-r--r--sys-apps/openrazer/Manifest2
-rw-r--r--sys-apps/openrazer/openrazer-3.5.0.ebuild160
2 files changed, 162 insertions, 0 deletions
diff --git a/sys-apps/openrazer/Manifest b/sys-apps/openrazer/Manifest
index d4b89cd41467..4b0e28d67103 100644
--- a/sys-apps/openrazer/Manifest
+++ b/sys-apps/openrazer/Manifest
@@ -1,3 +1,5 @@
DIST openrazer-3.4.0.tar.gz 233490 BLAKE2B dc5236e75b998c72c4ebc2420d2c5f3d996af19e87d91d4d76dca7098c6120a12b642c314eca037973f140e4679ab42d0f25ce5225bc97d9839468f8325de56b SHA512 ba9efb3ce2736365e453328e81683368df0ef894ac44ac79c7b34c5bd782b9394170a9528d58db954da880f18a5e72a3d84810ec11b5b34845eee7daa9babd22
+DIST openrazer-3.5.0.tar.gz 240079 BLAKE2B ac4565e01b7f8b4474d4cc2d64956dfce71a5ec96b1be1cec7d7418094d353d8156ea8ab30c7f87ccddb1fa92f18767e67ce931a4b58c7d248873bf6e86c1dbc SHA512 e7fb1b056777a779978f42739cf486e17dcf64024e612b270960981cf0a03b75de0e880497842a7c90b6e7727fd3cd35d4704e9abbe7a9f764957b0949a699ea
EBUILD openrazer-3.4.0-r3.ebuild 3714 BLAKE2B 4ae39e2c8488830a5294d891221cccaecb630f982457fc53ae44adada3b42dbab1ae5702146619c969efe9556d6b424a6a361eed906de7d904562f4f62df049a SHA512 5e31c2bd019be0e78b90d677690a4d1c2dd90dd67d7fec1fe4855abbee24c2817a2ba1e3d1d8996301ad300a81bfd2715a9436b3a86474420497b650d8c9077e
+EBUILD openrazer-3.5.0.ebuild 3714 BLAKE2B 4ae39e2c8488830a5294d891221cccaecb630f982457fc53ae44adada3b42dbab1ae5702146619c969efe9556d6b424a6a361eed906de7d904562f4f62df049a SHA512 5e31c2bd019be0e78b90d677690a4d1c2dd90dd67d7fec1fe4855abbee24c2817a2ba1e3d1d8996301ad300a81bfd2715a9436b3a86474420497b650d8c9077e
MISC metadata.xml 557 BLAKE2B c7d8fe83eb9f1d3d5361d816e6bad6abd2eea172e743a3482b1e67bb77019251b26b2ecb7d9d8e7efd4ada69990ea07735446771a836a64bd110cac6b72a626a SHA512 87490d202ae606a8f4d1fe63e5631c7eae1ae13f0705dc6553f79b351d6181183cc81c69b5740647298a48e35db407821835c8309db725b609f4bcfd8d0bdd56
diff --git a/sys-apps/openrazer/openrazer-3.5.0.ebuild b/sys-apps/openrazer/openrazer-3.5.0.ebuild
new file mode 100644
index 000000000000..7b19f04fe4bf
--- /dev/null
+++ b/sys-apps/openrazer/openrazer-3.5.0.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit readme.gentoo-r1 systemd udev xdg-utils distutils-r1 python-r1 linux-mod
+
+DESCRIPTION="Drivers and user-space daemon to control Razer devices on GNU/Linux"
+HOMEPAGE="https://openrazer.github.io/
+ https://github.com/openrazer/openrazer/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+client +daemon"
+REQUIRED_USE="
+ client? ( daemon )
+ daemon? ( ${PYTHON_REQUIRED_USE} )
+ test? ( daemon )
+"
+
+RDEPEND="
+ client? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ daemon? (
+ acct-group/plugdev
+ dev-python/daemonize[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xautomation
+ x11-misc/xdotool
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/linux-sources
+"
+
+DOCS=( README.md )
+
+DOC_CONTENTS="To successfully use OpenRazer: load desired kernel module
+(razeraccessory, razerkbd, razerkraken and/or razermouse),
+add your user to the \"plugdev\" group and start the OpenRazer daemon.
+To automatically start up the OpenRazer daemon on session login copy
+/usr/share/openrazer/openrazer-daemon.desktop file into Your user's
+~/.config/autostart/ directory."
+
+BUILD_TARGETS="clean driver"
+BUILD_PARAMS="-C ${S} SUBDIRS=${S}/driver KERNELDIR=${KERNEL_DIR}"
+MODULE_NAMES="
+ razeraccessory(hid:${S}/driver)
+ razerkbd(hid:${S}/driver)
+ razerkraken(hid:${S}/driver)
+ razermouse(hid:${S}/driver)
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ if use daemon ; then
+ ( cd "${S}"/daemon || die ; distutils-r1_python_compile )
+ fi
+ if use client ; then
+ ( cd "${S}"/pylib || die ; distutils-r1_python_compile )
+ fi
+}
+
+python_install() {
+ if use daemon ; then
+ ( cd "${S}"/daemon || die ; distutils-r1_python_install )
+ python_scriptinto /usr/bin
+ python_newscript "${S}"/daemon/run_openrazer_daemon.py ${PN}-daemon
+ fi
+ if use client ; then
+ ( cd "${S}"/pylib || die ; distutils-r1_python_install )
+ fi
+}
+
+src_prepare() {
+ xdg_environment_reset
+ distutils-r1_src_prepare
+
+ # Remove bad tests.
+ rm "${S}"/daemon/tests/test_effect_sync.py || die
+}
+
+src_compile() {
+ linux-mod_src_compile
+ distutils-r1_src_compile
+
+ if use daemon ; then
+ emake -C "${S}"/daemon PREFIX=/usr service
+ fi
+
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ ( cd "${S}"/daemon/tests || die ; distutils-r1_src_test )
+}
+
+src_install() {
+ linux-mod_src_install
+ distutils-r1_src_install
+
+ udev_dorules "${S}"/install_files/udev/99-razer.rules
+ exeinto "$(get_udevdir)"
+ doexe "${S}"/install_files/udev/razer_mount
+
+ # Install configuration example so that the daemon does not complain.
+ insinto /usr/share/${PN}
+ newins "${S}"/daemon/resources/razer.conf razer.conf.example
+
+ if use daemon ; then
+ # dbus service
+ insinto /usr/share/dbus-1/services
+ doins "${S}"/daemon/org.razer.service
+
+ # systemd unit
+ systemd_douserunit "${S}"/daemon/${PN}-daemon.service
+
+ # xdg autostart example file
+ insinto /usr/share/${PN}
+ doins "${S}"/install_files/desktop/openrazer-daemon.desktop
+
+ # Manpages
+ doman "${S}"/daemon/resources/man/${PN}-daemon.8
+ doman "${S}"/daemon/resources/man/razer.conf.5
+ fi
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+
+ if use daemon ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+
+ if use daemon ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}