summaryrefslogtreecommitdiff
path: root/sys-apps/opal-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /sys-apps/opal-utils
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'sys-apps/opal-utils')
-rw-r--r--sys-apps/opal-utils/Manifest2
-rw-r--r--sys-apps/opal-utils/opal-utils-6.8.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-apps/opal-utils/Manifest b/sys-apps/opal-utils/Manifest
index ed59c5aecd1f..b178fbd8e628 100644
--- a/sys-apps/opal-utils/Manifest
+++ b/sys-apps/opal-utils/Manifest
@@ -2,5 +2,7 @@ AUX flags.patch 1057 BLAKE2B 4b601dff49cfe1d82cc32b2fbb0c32922e9f049e010d1403b89
AUX opal-prd.confd 99 BLAKE2B 105ccd9e2d6d7d51ffc1a82b3fa174ae61ea4e945f679f82460f84bbf2036f4f7f3da2f8d9c66807a275aa98778d824f8ba5d50d1e5349fd17adbee032816290 SHA512 387ec1d00afeaf7c44e4ee5c7e6a3959e1465b7a8a9a121bf470105c23df1f906f23cedbd1006bed250f50a3c3a77f9f40ea62bafa6d6397dda2152c9dedda06
AUX opal-prd.initd 480 BLAKE2B 895440e30d5a136a717462f8890b3123ca4e31b75f1443f95020e98bf92b0a82f7c0536f828956ea5705c090bb598ab7d48f60653da0eab9bd904e234264ee9e SHA512 9a850a840697bcfeb272dffdabc80be321768fee91808562650d4162555212ce4c6639fd58832979fb710c2f2c78e7835dd99b435b22a64cae9810085d93f459
DIST opal-utils-6.7.tar.gz 5320182 BLAKE2B e2fa86a7d5d96afda8f8266875687fb3c2e61ca2932ea5585921b2e5cffe30cb3554d85d078448cda032cbc0438d188ea40b5aad6e7f4c923e77fa4e42e6f364 SHA512 1626d64554c608cd823dc27b58f35206cf6d011afde124746e06fd5f1e8c714c199d9f2b60417415daf01cfbc46208d08d49eef29538a515b539a551b8c5e5c3
+DIST opal-utils-6.8.tar.gz 5321377 BLAKE2B 3be812618dcbd3d877576e1dec0b6a74ad9091b59760bd8f1f67ba9a8efbce79cba4130464dcb6f2b8e61dedca3a1a60103f36d04fcd234b5a4c577c6e07635b SHA512 a799112c14abdcdb37e1a4c63e48e12bb7a67b6c90476d4e60597f06fd6050a58ffd25859cf6bb12c393522e4b4771ce3aa25a1277bac35855d599e9eb357814
EBUILD opal-utils-6.7.ebuild 2475 BLAKE2B de4715513ac5bf263634fd468ba762855ace15e63f678e6bc3b0a8faea353f12a76c1132fc85d29a33834fb1fbec4a2d6eada7299b3499fb82f6d7d4706f040d SHA512 9b22701b32998c75742714ecec9d6860463740ba4c0ff1252ac2b1b8c5b99f087304220302f2cc319c03d49ad459eb4ab3051547d852161e1e8df56b59f04aa1
+EBUILD opal-utils-6.8.ebuild 2480 BLAKE2B abbe19d2ff7cfb7701603efe72b2559931b469c1ef9d9348b7159390fe3e16b7bfc167ebf9783cdc5f027789bab10050bffd9dd0e57ca47c96401ec46cf01829 SHA512 3095b4aab7ee76985ec922517a2c1a6e36212997ef668668f992d4cf9f619a960ce0892446bdaf4e927a44c486a059b9b46134c0a86052e8b37445d0aec7ee31
MISC metadata.xml 1099 BLAKE2B 8715aef2781f806a58a094125d7c3ca6189a27a4d4c52ff6286905975a6b688921e09519f9968bb243c216611bab2da6507775c86e5e7293b9412d46ee7713da SHA512 d159348f48be29e96a84845474b1c6286ca29df1d62bec79a1a3385e89be0ac0b84a3465c41e769e447ac5598a189564f5e3e638668ea8c876b6899a1cb33666
diff --git a/sys-apps/opal-utils/opal-utils-6.8.ebuild b/sys-apps/opal-utils/opal-utils-6.8.ebuild
new file mode 100644
index 000000000000..ccb349721b3d
--- /dev/null
+++ b/sys-apps/opal-utils/opal-utils-6.8.ebuild
@@ -0,0 +1,93 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit linux-info python-single-r1 systemd toolchain-funcs
+
+DESCRIPTION="OPAL firmware utilities"
+HOMEPAGE="https://github.com/open-power/skiboot"
+SRC_URI="https://github.com/open-power/skiboot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~ppc64"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${DEPEND} ${PYTHON_DEPS}"
+
+BDEPEND="doc? ( $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]')
+)"
+
+CONFIG_CHECK="~MTD_POWERNV_FLASH ~OPAL_PRD ~PPC_DT_CPU_FTRS ~SCOM_DEBUGFS"
+ERROR_MTD_POWERND_FLASH="CONFIG_MTD_POWERND_FLASH is required to use pflash and opal-gard"
+ERROR_OPAL_PRD="CONFIG_OPAL_PRD is required to run opal-prd daemon"
+ERROR_SCOM_DEBUGFS="CONFIG_SCOM_DEBUGFS is required to use xscom-utils"
+
+S="${WORKDIR}/skiboot-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/flags.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ tc-export CC LD
+ export OPAL_PRD_VERSION="${PV}"
+ export GARD_VERSION="${PV}"
+ export PFLASH_VERSION="${PV}"
+ export XSCOM_VERSION="${PV}"
+ export FFSPART_VERSION="${PV}"
+}
+
+src_compile() {
+ emake V=1 -C external/opal-prd
+ emake V=1 -C external/gard
+ emake V=1 -C external/pflash
+ emake V=1 -C external/xscom-utils
+ emake V=1 -C external/ffspart
+
+ use doc && emake V=1 -C doc html
+}
+
+src_install() {
+ emake -C external/opal-prd DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/gard DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/pflash DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/xscom-utils DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ dosbin external/ffspart/ffspart
+
+ python_domodule external/pci-scripts/ppc.py
+ python_doscript external/pci-scripts/phberr.py
+
+ newinitd "${FILESDIR}"/opal-prd.initd opal-prd
+ newconfd "${FILESDIR}"/opal-prd.confd opal-prd
+
+ systemd_dounit external/opal-prd/opal-prd.service
+
+ if use doc; then
+ rm -r doc/_build/html/_sources || die
+ local HTML_DOCS=( doc/_build/html/. )
+ fi
+ einstalldocs
+}
+
+src_test() {
+ emake V=1 -C external/opal-prd test
+ emake V=1 -C external/gard check
+ # this test is fragile and fails because of filename path
+ rm external/pflash/test/tests/01-info || die
+ emake V=1 -C external/pflash check
+ emake V=1 -C external/ffspart check
+}