summaryrefslogtreecommitdiff
path: root/sys-apps/musl-locales
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-16 01:40:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-16 01:40:03 +0100
commit98dd97c6dc5b5b4ad4bb19efeb7f314cc52f43ff (patch)
tree4e8e5247d2b6daea3cdd2839960281e1876613cb /sys-apps/musl-locales
parent3ba87279363a3a099c83d72faaf5b6bee1b23304 (diff)
gentoo auto-resync : 16:06:2023 - 01:40:03
Diffstat (limited to 'sys-apps/musl-locales')
-rw-r--r--sys-apps/musl-locales/Manifest3
-rw-r--r--sys-apps/musl-locales/metadata.xml7
-rw-r--r--sys-apps/musl-locales/musl-locales-0.1.0.ebuild23
3 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/musl-locales/Manifest b/sys-apps/musl-locales/Manifest
new file mode 100644
index 000000000000..68fa13a7e6b9
--- /dev/null
+++ b/sys-apps/musl-locales/Manifest
@@ -0,0 +1,3 @@
+DIST musl-locales-0.1.0.tar.xz 26744 BLAKE2B 9ad696e7006a124f2e633e3f5476b68806659ddeac2e7cbd0ce485087870463256f3dcc11c3d37074cfc863ce8afed1b31bdf7c80435cce182fce95e81bf16b0 SHA512 bc1e581676ef21aa22b85932186189ba5fd0b1701feef4906f42baa296a90fc6886101d02a46a9560b883aad42aa4808ed46c5dddc09d97d1a0f75943a0d456a
+EBUILD musl-locales-0.1.0.ebuild 501 BLAKE2B 6d0b46ecc9c336e0f307bb7fa53bf046f025f22f0bc230d624bb72dc2091a55ad4fd7e99adf7dbdce755c57bfb657a94732ac4533963b22b18a8429faabddeae SHA512 ee9d90fbe08879a20ff4917544bbe1651d7d83d182a37215c4b0e4ebf0c0661a625d168243f0cafea7255e90be1f7dc00925b941ec38008194afcb40a1ae2061
+MISC metadata.xml 217 BLAKE2B b827888fdd4e1572aade77387c9e6e702b7637e5fb50e47c163308d2e1609967e473611061373febf39543bd178c2b753ed43043b5d3e875e1dc30ddaa5db943 SHA512 a425ec31e1d9f15041755a5b4102c69b4500955ffe8872a6bc90b8ccb731693ee1c6a194928c0e042ffbaa8e09818d170baac66e1b2b5fc6940cf80a4356369e
diff --git a/sys-apps/musl-locales/metadata.xml b/sys-apps/musl-locales/metadata.xml
new file mode 100644
index 000000000000..6b00211d29ea
--- /dev/null
+++ b/sys-apps/musl-locales/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>musl@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/musl-locales/musl-locales-0.1.0.ebuild b/sys-apps/musl-locales/musl-locales-0.1.0.ebuild
new file mode 100644
index 000000000000..d59081b1ed0d
--- /dev/null
+++ b/sys-apps/musl-locales/musl-locales-0.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Locale program for musl libc"
+HOMEPAGE="https://git.adelielinux.org/adelie/musl-locales"
+SRC_URI="https://git.adelielinux.org/adelie/musl-locales/uploads/7e855b894b18ca4bf4ecb11b5bcbc4c1/${P}.tar.xz"
+
+LICENSE="LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="!sys-libs/glibc"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALE_PROFILE=OFF
+ )
+ cmake_src_configure
+}