summaryrefslogtreecommitdiff
path: root/sys-apps/most
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sys-apps/most
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sys-apps/most')
-rw-r--r--sys-apps/most/Manifest2
-rw-r--r--sys-apps/most/most-5.2.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/most/Manifest b/sys-apps/most/Manifest
index b534edfcaac3..f673d2a5de2f 100644
--- a/sys-apps/most/Manifest
+++ b/sys-apps/most/Manifest
@@ -1,5 +1,7 @@
AUX most-5.0.0a-donot-hardcode-path.patch 969 BLAKE2B 1089149fc01a3081760f422b73d4a691e3078f13df1a7045cf0f94d6991c762e4004088e9a0b89a9b6b39ec70782f1b86edb13c714ef2b2b33bd6ccd9f18435d SHA512 6da3424b5e9763bd8f89998ffe019230cc8e9c7fc9722235cc13830d50647f590f6a934ae025a063fe8fc1e8bdd2b4fc067fbc1569c7a0ebfa220b868b999271
AUX most-5.1.0-fix-parallel-build.patch 761 BLAKE2B b2aeb5019305138ee0ac816c07595afcf95c07f7d3f477ace41931fcb85706909813056f9291d5002e2e583fdd3baec34f09b153a9d736e0009d3d7f6f4cf524 SHA512 492ebbc35c4a94514c252541a644c45b4904ad402fa0c45da03f9acb529dfdf46576429b67352cfde9defd76b772aa12ecd449f461b3f995a4d00f9ed63692c5
DIST most-5.1.0.tar.gz 162172 BLAKE2B a3c0f3d85e7c4f4a014c174efb0d3d22b0fc2758e403ddccc74308399eeec616800e16db33554f0ca53fba674efba9dd93d51ed0c3f887b2c24fd3dd2335387c SHA512 cbc090283bbaafb8ffee9d6d1abc7b49cd58d54b742cf8dc86274351dee6398d1f24841bd1631ac40f861ad9e23569646133d3297317d9d514a7a38dd74533d2
+DIST most-5.2.0.tar.gz 256075 BLAKE2B ae73680cedb0306dd6980c637fd8c0d016537663ab707e925931972822f718dd31fc80d83598af9832c7869b5abf4ec3333bc076ce56c4a6d42f71d30be1a50d SHA512 3aa3cb46ddd456532a009fb9cfcd746971396be33e03e52a15b754a6d7683f4efd020edb0ec4eb36d22ba20f050aaac4ba6cdd3b69bb5701ea58ddb9a903c59d
EBUILD most-5.1.0.ebuild 917 BLAKE2B 14508a5b03c06d1fa4f94eb5b25710dfd6ebab34de570b360fc9cc3150fd1309d1d5ba39913ae1fce96af420fa416db6cda271ebcf2c29863a27555d7bd57c50 SHA512 87941a9e5a52f001519074a5e22146e453a253736bf0cf22939d4f6e6876df77e898951e8ed0ea22535bf98ad8e8c1dde4265027f99b22568831208a168cea6e
+EBUILD most-5.2.0.ebuild 877 BLAKE2B 166f782883e6a576e8160b45f2702ec06bf4a088440c9ed4e419828d41f1c949458d9b7f679c626941205a478b72a2aa88277a1bd9644d7426f8ac80152b7543 SHA512 8ec470897022752c45aca24adea4927ccc34add4200c3207879aa4936d4893a641068b9b9004f6803ca6603b0831683d584a50bc9ed1b5521ae77fe56a3c707a
MISC metadata.xml 353 BLAKE2B 20b4dc12fbe79c13693505e5b0861b89c10f7e89fe0e616550f5e74fb19049b3a7037fc05695ad6c0f29638251d53a9adab2a50c0216da6d77a1b45b1eace811 SHA512 a91058c3bbe915315fe012250d3c9f7be38d7f9a19980cc2df2ccfb102c82ab2eeb8931b47d7350363149a6302dd3d75128d9cf48237f55fbc866155440614e9
diff --git a/sys-apps/most/most-5.2.0.ebuild b/sys-apps/most/most-5.2.0.ebuild
new file mode 100644
index 000000000000..20f8f9098a74
--- /dev/null
+++ b/sys-apps/most/most-5.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Paging program that displays, one windowful at a time, the contents of a file"
+HOMEPAGE="https://www.jedsoft.org/most/"
+SRC_URI="https://www.jedsoft.org/releases/${PN}/${P}.tar.gz
+ https://www.jedsoft.org/releases/${PN}/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND=">=sys-libs/slang-2.1.3"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.0a-donot-hardcode-path.patch
+)
+
+src_prepare() {
+ default
+ # Do not strip by default
+ sed -e '/\$(INSTALL)/s@ -s@@' -i src/Makefile.in || die
+}
+
+src_configure() {
+ unset ARCH
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+}