summaryrefslogtreecommitdiff
path: root/sys-apps/moar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-28 10:02:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-28 10:02:11 +0100
commit9967860c0cd26c0940ee4b9ab6698e00e5b1260a (patch)
tree000be053853792419070a7d8f64379ec7ca7bc8b /sys-apps/moar
parentefc1a67ef36757bc76eb899ec03802086adda461 (diff)
gentoo auto-resync : 28:08:2023 - 10:02:11
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest3
-rw-r--r--sys-apps/moar/moar-1.15.4.ebuild41
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index cfd5d185c2e4..1196675550ea 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -1,4 +1,7 @@
DIST moar-1.15.3-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
DIST moar-1.15.3.tar.gz 2781596 BLAKE2B 36e908245fbdebb89e2ed5cc1ef80c2000aeb03d8f35b84dff6d7e8b270d337d3dec9829d718d576e6ca4b0a6ac8694c5fa72b167a67dd3e7cde97ff06f7bfc5 SHA512 cce9eef06af14c320527a1b6a1832608b8267b9453eafb1153677aea98372e3fc3800e2a8938e9460e0f914c72f5c31380a0ee8ff0bd7db903756bea5352b424
+DIST moar-1.15.4-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
+DIST moar-1.15.4.tar.gz 2782491 BLAKE2B 467429bbc9dae085065ebc17e1b8b56ebe67b0cd8f4675a72f9032150513876f66dbddf4a3e9baa8d921cbb0779aea24b51a10f9af628c64724313aa60ab4ecc SHA512 c4068fbf1a8ea64d8a169f2aa8e73d6dedc4cc781ebd011dcdae4093f277843566f88d4e087417f3e02097e252653e487547b8dbe6889dd06a5d9956c9b93a67
EBUILD moar-1.15.3.ebuild 920 BLAKE2B 007b8b5b6d68f7514a8acd18fe82426c27a041c32a2c435a013ad97b6370bc87c9096e5ae7adb1796413bb1cf5b2b2e272456a1499a88c87ec9065c448267dde SHA512 30578a05fd5cb46245abcb6791897b1e00f099e07efcdf792f84f413cb11f0df18ebdf2bc34ff0eefdbefa1b56cb05e9e771d27d1c286948fbb405bb40b4b709
+EBUILD moar-1.15.4.ebuild 920 BLAKE2B 007b8b5b6d68f7514a8acd18fe82426c27a041c32a2c435a013ad97b6370bc87c9096e5ae7adb1796413bb1cf5b2b2e272456a1499a88c87ec9065c448267dde SHA512 30578a05fd5cb46245abcb6791897b1e00f099e07efcdf792f84f413cb11f0df18ebdf2bc34ff0eefdbefa1b56cb05e9e771d27d1c286948fbb405bb40b4b709
MISC metadata.xml 316 BLAKE2B 19b5d071afbcad1f05744cca494156dc634f3fc35afaf4828dcf1e691e75a0f47f162b6cf548e5a333441f25327970f6a71d6acb436b60a68deeb7fb44659d45 SHA512 44155ffd972d79d47e41fe2ed38583e41eaaeb9f6b0de7e52b666930906f561e73d1f604acf602750ae1bed50e516dbbe36327b47ba2005813438e0d2db070e1
diff --git a/sys-apps/moar/moar-1.15.4.ebuild b/sys-apps/moar/moar-1.15.4.ebuild
new file mode 100644
index 000000000000..a32bbea5ec05
--- /dev/null
+++ b/sys-apps/moar/moar-1.15.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}