summaryrefslogtreecommitdiff
path: root/sys-apps/moar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sys-apps/moar
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest4
-rw-r--r--sys-apps/moar/metadata.xml11
-rw-r--r--sys-apps/moar/moar-1.11.3-r1.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
new file mode 100644
index 000000000000..4122989aaa14
--- /dev/null
+++ b/sys-apps/moar/Manifest
@@ -0,0 +1,4 @@
+DIST moar-1.11.3-deps.tar.xz 25971908 BLAKE2B b0086ed53e9b032bc58e048ce5e5298cbee21e67b85798b2aa58c661293f53383a2191a7bef203a098c954ffc20dc7094e4a0c7b57aa8b456543b42770f30916 SHA512 215db80539767b4900ecac56f84a9f183f9e0581fb7603219feb3e1da44b10b52e7eda69336fc0ed6ab73be3e4efee855a91d3a41b1839c8cb9f357a9b2ed455
+DIST moar-1.11.3.tar.gz 2777421 BLAKE2B 48cc596af11b1163a6ca6cc766670ec917fae4f7232c295e6d87f074ce3c87dd3f06ac440af4d5bedc2735a2d2fe634df2d9f5db8ad05399f470d99c406a7beb SHA512 2367dd81bea3ff20c782aa7b73a70ca2ff54d57164bbcf5e318bca3769adddc8c41c3092cee5bf9c02816c68d4f65200c118e17014ae37ed63b1436dde64688c
+EBUILD moar-1.11.3-r1.ebuild 813 BLAKE2B b2dbf35230b55ab7740758b96ce47eb5c0b2d96645a63af3492102fdf7cc63310fa0ad9e4749bb2412f7118384a4ac2a818fa9132136e66378c32502c092df5d SHA512 26eb33642cf62841cf2f1939e7c1898004446fd92ecd926fe367c6507de8e9e5e7b68e2252908212b7abbed50f3cf1ac8599cea2088f02f07a4a91bf5035f552
+MISC metadata.xml 316 BLAKE2B 19b5d071afbcad1f05744cca494156dc634f3fc35afaf4828dcf1e691e75a0f47f162b6cf548e5a333441f25327970f6a71d6acb436b60a68deeb7fb44659d45 SHA512 44155ffd972d79d47e41fe2ed38583e41eaaeb9f6b0de7e52b666930906f561e73d1f604acf602750ae1bed50e516dbbe36327b47ba2005813438e0d2db070e1
diff --git a/sys-apps/moar/metadata.xml b/sys-apps/moar/metadata.xml
new file mode 100644
index 000000000000..da115d6b24cf
--- /dev/null
+++ b/sys-apps/moar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">walles/moar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/moar/moar-1.11.3-r1.ebuild b/sys-apps/moar/moar-1.11.3-r1.ebuild
new file mode 100644
index 000000000000..766ab4317b72
--- /dev/null
+++ b/sys-apps/moar/moar-1.11.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="!dev-lang/moarvm"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}