summaryrefslogtreecommitdiff
path: root/sys-apps/miscfiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-apps/miscfiles
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-apps/miscfiles')
-rw-r--r--sys-apps/miscfiles/Manifest1
-rw-r--r--sys-apps/miscfiles/miscfiles-1.5-r4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/miscfiles/Manifest b/sys-apps/miscfiles/Manifest
index 1d6534f85e2f..51bd81adc638 100644
--- a/sys-apps/miscfiles/Manifest
+++ b/sys-apps/miscfiles/Manifest
@@ -1,4 +1,5 @@
DIST UnicodeData-10.0.0.txt.xz 158456 BLAKE2B 2f4442c4bb26639e748f6a2b799e128ec9ffee357e13524ee4fe54e8df37b2916b03a209c71681b5049aefe000a896898e23879b7fccc7066e42061b42515b2e SHA512 85e8c7b33d71025a5f6f109e28010a5d5167f1aeb86c88eedd2e5ea5cecae3d1be741e5b0113a78566f51e8e15812a180a8c43c6b887385fec157d744c7a4a9c
DIST miscfiles-1.5.tar.gz 1585293 BLAKE2B 816197e72192e8b41839eb29d501a148f95496a7f3e7be469184e9396cc34fc95c161207edb60a5b7f8d43fe50c58202f0b16b2e4b1ce188527718e4f85e24bb SHA512 d7ab23a709539278cce59e0c32bfcb3a0f11dc52ef537e3823e72382962af7f4fedb8b957f39ff1da51a93a00e3c4f6ec29f7332d7879c77fd7f4ec0ee4f82aa
EBUILD miscfiles-1.5-r3.ebuild 1700 BLAKE2B 366872b7f95d837bfe179e40b2c0562bfd756e12619fd695c1427c965f1f59c5aab4e418578122b8e733b7fed373e993070d174489c5fe24215fb7a62a389941 SHA512 78ab9a62e854e0f2801119c309d25443d057577c6e406f03c06000461ed2131d7e1388b6065cd9524ac1c783f5ae51aca0d18e35f481459b0e2deec93df5397e
+EBUILD miscfiles-1.5-r4.ebuild 1696 BLAKE2B 2117860031f78221ac13387d7f8811e453f49031494843db32f050c67076baccd6291d1ee3e6cfef05f2bf968e64c368d1f603c24e571402dab637b940defa53 SHA512 790435250bc83480e71a35a9fc4bbb5cfbe044c46b30d030017e1f31e45a65bd4240c26e31cc3fea9deeb25f699b8827856707fc1a144b1c587ebbf37a74310c
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild b/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild
new file mode 100644
index 000000000000..7ecdbacf6c43
--- /dev/null
+++ b/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+UNI_PV="10.0.0"
+DESCRIPTION="Miscellaneous files"
+HOMEPAGE="https://savannah.gnu.org/projects/miscfiles/"
+# https://www.unicode.org/Public/${UNI_PV}/ucd/UnicodeData.txt
+SRC_URI="mirror://gnu/miscfiles/${P}.tar.gz
+ https://dev.gentoo.org/~whissi/dist/${PN}/UnicodeData-${UNI_PV}.txt.xz"
+
+LICENSE="GPL-2 unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="minimal"
+
+src_prepare() {
+ default
+
+ mv "${WORKDIR}"/UnicodeData-${UNI_PV}.txt unicode || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/usr/share/misc
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc NEWS ORIGIN README dict-README
+
+ # not sure if this is still needed ...
+ dodir /usr/share/dict
+ cd "${ED}"/usr/share/misc || die
+ mv $(awk '$1=="dictfiles"{$1="";$2="";print}' "${S}"/Makefile) ../dict/ || die
+ cd ../dict || die
+ ln -s web2 words || die
+ ln -s web2a extra.words || die
+
+ if use minimal ; then
+ pushd "${ED}"/usr/share/dict || die
+ rm -f words extra.words || die
+ gzip -9 * || die
+ ln -s web2.gz words || die
+ ln -s web2a.gz extra.words || die
+ ln -s connectives{.gz,} || die
+ ln -s propernames{.gz,} || die
+ popd || die
+ rm -r "${ED}"/usr/share/misc || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${ROOT} ]] && type -P create-cracklib-dict >/dev/null ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+
+ # pkg_postinst isn't supposed to fail
+ return 0
+}