summaryrefslogtreecommitdiff
path: root/sys-apps/miller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sys-apps/miller
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sys-apps/miller')
-rw-r--r--sys-apps/miller/Manifest2
-rw-r--r--sys-apps/miller/miller-5.10.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/miller/Manifest b/sys-apps/miller/Manifest
index a20a35ae0af8..55ec898c869f 100644
--- a/sys-apps/miller/Manifest
+++ b/sys-apps/miller/Manifest
@@ -1,3 +1,5 @@
+DIST miller-5.10.0.tar.gz 6793426 BLAKE2B 25ec96e29ee8d913feffd6e9a54cd2d494c9050e180556ed462a6d94a6adaaea88dbdbc09b4753f8888673bdc33a1f0aa43f9dac37bdc3c25191b2a565fe8847 SHA512 a7cbaee9ad4075d27e74ab3a60297164c535ea2bc1e38128174f4f226ad061850d37108e7d7547821b7e6667cb9a024639795d7678b1897fedf6ee15d6064538
DIST miller-5.3.0.tar.gz 4940072 BLAKE2B 2e34ae010d409877040a60b08dd615f32e6945ca3bf97c078c89b9d2811067fa4bca2403f8ad239f8245e050acb10305d351b1db4177541a4fa9ed9a4bc1396c SHA512 4c557d97eb1cda2e52093fa097677602491895dea3093776a03af56114022b8c0917df9fbf26071d4d1a3c1360f520c82e33b32635c7b4207fa62869ab564712
+EBUILD miller-5.10.0.ebuild 1047 BLAKE2B bdd7d5d896950ce6c0ce71921839a51d6adb56b96224f9a811a1b5bc52a52e1d7074b4f60e4a7ff4211d9cac34560df3e0e15d8f5ad608cce763e5657c0ba4b2 SHA512 d7bcbbff6133465f6bf31a8ff783f22c60cd738a191ed1ebdbb7217c0dfe66b541ffbdfa467503d59749234c16fd3ec8760ab4d29cc00ee2bccad31268833486
EBUILD miller-5.3.0.ebuild 1043 BLAKE2B bd9aba828d1e446d70ef561f9930eecf7ffb02030c03d03c779122d7e0d6362f8ddb7bde63a609b253aa5be45fd384c81ad272279e5835cb2ed573422b83faba SHA512 28594f3915eaa1e7bf01405db64a14551d476eae0ece718bf5c7c1ec36a78cddc037c04ceb500a599ab69a6bb4b2ab109e9720e6a1e31a7a216637a823764be2
MISC metadata.xml 245 BLAKE2B 183034a40812aee01ddfd5d59eac1d2d1d42d281575fd5a3c900bd96af21cad81f9262b41f81c39f34dc60078ffa3db70149f8d50ecb09cb6003ed8602ab3ecd SHA512 b7b2cb8f6f35a36afa6a90e1d66747c2bc3e26a202483ec1d5c32346e75a738ee59be158af291a18c55140486d519c159492d12e3d25134ec20cc03fd7627cad
diff --git a/sys-apps/miller/miller-5.10.0.ebuild b/sys-apps/miller/miller-5.10.0.ebuild
new file mode 100644
index 000000000000..e0e1b73a7b1a
--- /dev/null
+++ b/sys-apps/miller/miller-5.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A tool like sed, awk, cut, join, and sort for name-indexed data (CSV, JSON, ..)"
+HOMEPAGE="https://johnkerl.org/miller/doc/index.html"
+SRC_URI="https://github.com/johnkerl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+
+ # respect flags
+ find -type f -name "Makefile.am" -exec sed -i -r -e '/.*FLAGS[^=]*=/ s:(-g|-pg|-O[0-9]) ::g' -- {} \; || die
+
+ # disable docs rebuilding as they're shipped prebuilt
+ sed -e '/SUBDIRS[^=]*=/ s:doc::g' -i -- Makefile.am || die
+
+ # disable building tests automagically
+ if ! use test; then
+ sed -e '/SUBDIRS[^=]*=/ s:[^ ]*_test::g' -i -- c/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_test() {
+ emake -C c/reg_test
+ emake -C c/unit_test
+}
+
+src_install() {
+ local HTML_DOCS=( $(usev doc) )
+
+ default
+
+ doman 'docs/mlr.1'
+}