summaryrefslogtreecommitdiff
path: root/sys-apps/memtester
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /sys-apps/memtester
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'sys-apps/memtester')
-rw-r--r--sys-apps/memtester/Manifest3
-rw-r--r--sys-apps/memtester/files/memtester-4.3.0-fix-gcc10-fno-common.patch31
-rw-r--r--sys-apps/memtester/memtester-4.3.0.ebuild16
3 files changed, 42 insertions, 8 deletions
diff --git a/sys-apps/memtester/Manifest b/sys-apps/memtester/Manifest
index 0801cf31e9ad..86388c8fa515 100644
--- a/sys-apps/memtester/Manifest
+++ b/sys-apps/memtester/Manifest
@@ -1,3 +1,4 @@
+AUX memtester-4.3.0-fix-gcc10-fno-common.patch 514 BLAKE2B 5b911fcd0ca63030e471f8e0e721f808ff8161d5cb14e51bec33bb61313154cab746880d162371a0a05b0c7fd4d165a90d5ad850f7d03139bdcdd7d5a24a5430 SHA512 ee0c21c40185fefe32d55c9f2b704db2b769189d6902369dc77078417fd7babdf6d2a6ba34dc4db2a8203bbe72148476d167550e8488477c4cd4a7bc221951f8
DIST memtester-4.3.0.tar.gz 22113 BLAKE2B 564cb874ea8263e23049d99417bb75f4d9f6fe1bbc022b2f2043735548c97f0060e877079087e524738bda3f9669d0ec171fb3aa9958a2904d848ace87d1cd91 SHA512 045bcc73855706ff03e8ca65297a0d6e5b5ac02f99dae0f17cef1310b403efcb78d9a7295eca6d2de703b0a7b2f71b58a37f5a42040f01fc77a321a8d2205888
-EBUILD memtester-4.3.0.ebuild 716 BLAKE2B 33911a95eefdf9b76df8bf3828528ff37836cbfdbd6b5a22c4ee2795110b6f33fc3f1365d3d5ef948e7148d01c5779831c4271adea9659c7ca0909d366733112 SHA512 976bc16d7b2acb0ad6c31d67c979be77e3ef351a2b8f949b235a3cd916d4047af71a0fda3fffec6cc2573fe4a27385baf5bc3421864d7c71f661a9d60ba9a233
+EBUILD memtester-4.3.0.ebuild 787 BLAKE2B 732b507aea997202701c14d12521511ad0365835ac3925b5aa9e207f25fd7b50ebb93281e1deaf64ee9fd7c2ebf62a6d2a14501ba1a83ca13017cd2929833d70 SHA512 227695b1358e01bd9c3162673f8ad017481b8271f62e231a638e33f34806cb366f3369ce5a1e66c9befd5789e7c40cc231b585a30f348633502106b8220517ec
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/memtester/files/memtester-4.3.0-fix-gcc10-fno-common.patch b/sys-apps/memtester/files/memtester-4.3.0-fix-gcc10-fno-common.patch
new file mode 100644
index 000000000000..8bb58e5771c0
--- /dev/null
+++ b/sys-apps/memtester/files/memtester-4.3.0-fix-gcc10-fno-common.patch
@@ -0,0 +1,31 @@
+--- a/tests.c
++++ b/tests.c
+@@ -27,6 +27,9 @@
+ #define PROGRESSOFTEN 2500
+ #define ONE 0x00000001L
+
++union mword8_type mword8;
++union mword16_type mword16;
++
+ /* Function definitions. */
+
+ int compare_regions(ulv *bufa, ulv *bufb, size_t count) {
+--- a/types.h
++++ b/types.h
+@@ -25,12 +25,12 @@
+ int (*fp)();
+ };
+
+-union {
++union mword8_type {
+ unsigned char bytes[UL_LEN/8];
+ ul val;
+-} mword8;
++};
+
+-union {
++union mword16_type {
+ unsigned short u16s[UL_LEN/16];
+ ul val;
+-} mword16;
++};
diff --git a/sys-apps/memtester/memtester-4.3.0.ebuild b/sys-apps/memtester/memtester-4.3.0.ebuild
index 56a07613ef14..cccff64b5d43 100644
--- a/sys-apps/memtester/memtester-4.3.0.ebuild
+++ b/sys-apps/memtester/memtester-4.3.0.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="userspace utility for testing the memory subsystem for faults"
HOMEPAGE="http://pyropus.ca/software/memtester/"
-SRC_URI="http://pyropus.ca/software/memtester/${P}.tar.gz
+SRC_URI="
+ http://pyropus.ca/software/memtester/${P}.tar.gz
http://pyropus.ca/software/memtester/old-versions/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-src_prepare() {
- echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc
- echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld
+PATCHES=( "${FILESDIR}"/${PN}-4.3.0-fix-gcc10-fno-common.patch )
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
}
src_install() {