summaryrefslogtreecommitdiff
path: root/sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch')
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch b/sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch
new file mode 100644
index 000000000000..f3faf1392b3a
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-5.31b-test-random-cflags.patch
@@ -0,0 +1,17 @@
+make sure we re-use the existing CFLAGS settings so that we get all the right
+flags (like -fno-stack-protector). just append the few changes we want (the
+optimization levels).
+
+https://bugs.gentoo.org/590974
+
+--- a/Makefile
++++ b/Makefile
+@@ -65,7 +65,7 @@
+ $(CC) -Wall -Werror -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector -c -o memsize.o memsize.c
+
+ random.o: random.c
+- $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
++random.o: CFLAGS += -O3 -fno-PIC
+
+ clean:
+ rm -f *.o *.s *.iso memtest.bin memtest memtest_shared \