summaryrefslogtreecommitdiff
path: root/sys-apps/man-db/man-db-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /sys-apps/man-db/man-db-9999.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'sys-apps/man-db/man-db-9999.ebuild')
-rw-r--r--sys-apps/man-db/man-db-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-apps/man-db/man-db-9999.ebuild b/sys-apps/man-db/man-db-9999.ebuild
index 10986291516d..ef05ecd8416f 100644
--- a/sys-apps/man-db/man-db-9999.ebuild
+++ b/sys-apps/man-db/man-db-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit systemd prefix tmpfiles
-DESCRIPTION="A man replacement that utilizes berkdb instead of flat files"
+DESCRIPTION="A man replacement that utilizes dbm instead of flat files"
HOMEPAGE="https://gitlab.com/cjwatson/man-db https://www.nongnu.org/man-db/"
if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
@@ -18,13 +18,12 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="berkdb +manpager nls +seccomp selinux static-libs zlib"
+IUSE="+manpager nls +seccomp selinux static-libs zlib"
-CDEPEND="!sys-apps/man
+CDEPEND="
>=dev-libs/libpipeline-1.5.0
sys-apps/groff
- !berkdb? ( sys-libs/gdbm:= )
- berkdb? ( sys-libs/db:= )
+ sys-libs/gdbm:=
seccomp? ( sys-libs/libseccomp )
zlib? ( sys-libs/zlib )"
DEPEND="${CDEPEND}"
@@ -117,7 +116,7 @@ src_configure() {
$(use_enable static-libs static)
$(use_with seccomp libseccomp)
- --with-db=$(usex berkdb db gdbm)
+ --with-db=gdbm
)
case ${CHOST} in