summaryrefslogtreecommitdiff
path: root/sys-apps/logwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 06:54:34 +0000
commit9a1d1c6b10a4640cea10e7040ed173cf593f4cab (patch)
tree10b7aaa9608311a4b8a7561c6a8da3003ebb061d /sys-apps/logwatch
parentdefbebad0d311b0ce0694b17989a9f26cf000250 (diff)
gentoo auto-resync : 23:01:2023 - 06:54:34
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest2
-rw-r--r--sys-apps/logwatch/logwatch-7.8.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 1aeafde46fc1..aeae70e019ee 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,6 +1,8 @@
AUX logwatch 125 BLAKE2B 93e0bb2e65dda3a81e1bf560c06a3739fc2226488492219fab478326e8a05051077cfd6ee604d3ebd7aaa2329687a0f3facdb2741e99bf9ea4207a939a16f885 SHA512 20cdf61fe9e9bfe336c6b7e1f33c982c34e61370431179a2f766da8e1b56f8452c85d75fbba4f459f9c4761a7a932c309d0ba7253aeb6e3b31b220c00106e504
AUX logwatch.tmpfile 39 BLAKE2B 9b1df0ad28bdc16373e71eedb05e8962bf4eda5d564ba8e2632af8158fa3346e8784db2a6bf9aa90c04768743aee6eaefae517feb9f7066d748cae894c1a2299 SHA512 7902aab160b5fd6e1bb1573777f9fab065ed33b0df19da2b5dad31ca962eaea93f9d46e57efca2d76df26c55b48e0578fddf4136e36ed565d8a2b5258dc34afd
DIST logwatch-7.7.tar.gz 498214 BLAKE2B 8978930fe844bde372f68038f295cc62ca61f1c2b10d18f545ddcc713cb72cd01520ff0ea0869f2dff96846431a6dd9a04da1bc79817ccb590b0235f96e934da SHA512 5224013c548e60248ef2de8aeabc760d046374f54035e7e5e00bba0c6e6777eb5e7fcfd05a9f029d3d34e9d3fb8a243ed99b417961b21895cc14b881f1ad3dd4
+DIST logwatch-7.8.tar.gz 496093 BLAKE2B 35480a22077e43b70d15a00cc0a3a8297c1e57c465d6fffe7a9a68a9b4fb14ef62c1d2bcae8a4ab2d70af16451b8f0b5dba8aec29beae1012501a118915edd92 SHA512 470b45e5838014986292c65b7e95e7922fb5364d0d375d413f710968523273372e049774a25aab58a685bf0cfe999c8ffa0c2280fc29aa83b1603256659511d9
EBUILD logwatch-7.7.ebuild 2405 BLAKE2B 3955dd13d7d123f453e0c426aeaeb7e0a27d982e907f598ae621b31bbf5fa5710a86d995bddb18a8932eb5e6d2f4cfaa69f964903dfef86ee58a322ea51e3b12 SHA512 5b888b1fca220786a73bd524df55997c5c05e798877fb3951287895b393c845b1503924a9ac5fd652bf9c48d6fd7919bbd4d1110a9d89d17e787f904ca61e7df
+EBUILD logwatch-7.8.ebuild 2413 BLAKE2B 94d02845444e44874b90d7f8bd21131cc754f5b84a90f4581c0d1dfcba041fad463ef2516ac5e1750f15cc2da237de2f41024011bb321115419aac311ae97ae6 SHA512 8038461b668f1d3ddd5908d866db147d350699fbc26333e8716b8efc4ec145e33656668c34536f2341348ed92dfb0b9bf8486a532daf7ac31850dc3177fbc980
EBUILD logwatch-9999.ebuild 2413 BLAKE2B f846a4b0f713e757baaacc811b97ad37456b58b255ab616b8debbaafbc9ed754a214f71fc1f8da0c86aff2df3b70b199e0f28322a359a2514028e4782fd31ee3 SHA512 a59f67d27700d7fc8e6910e846bbb975dacd92098f5f3752ac8c6c7e7968a0fe40dce3267f69c7e853b0e3bcbedf92105f2faf137ec6308c302a261821c4d38e
MISC metadata.xml 329 BLAKE2B ae6bfb6282dd2f5ddc01959eb57e894cc12a69de5fea771439d9b2a95110754fd7c35db97ee238865cfb81333800dcdcfb42654d12572e16cde12c7212a505c5 SHA512 a523f269535d7e0272f2d66b903319197f52477dbf40b32729eff93b5788f9c8b8756a4750128f894b4ab0d05b9effbac5d350e5ae2ab68474ef4fa39022710a
diff --git a/sys-apps/logwatch/logwatch-7.8.ebuild b/sys-apps/logwatch/logwatch-7.8.ebuild
new file mode 100644
index 000000000000..3147899cb63c
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.8.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}