summaryrefslogtreecommitdiff
path: root/sys-apps/logwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /sys-apps/logwatch
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest2
-rw-r--r--sys-apps/logwatch/logwatch-7.10.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 0def535f845c..df90c7b8cb3e 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,6 +1,8 @@
AUX logwatch 125 BLAKE2B 93e0bb2e65dda3a81e1bf560c06a3739fc2226488492219fab478326e8a05051077cfd6ee604d3ebd7aaa2329687a0f3facdb2741e99bf9ea4207a939a16f885 SHA512 20cdf61fe9e9bfe336c6b7e1f33c982c34e61370431179a2f766da8e1b56f8452c85d75fbba4f459f9c4761a7a932c309d0ba7253aeb6e3b31b220c00106e504
AUX logwatch.tmpfile 39 BLAKE2B 9b1df0ad28bdc16373e71eedb05e8962bf4eda5d564ba8e2632af8158fa3346e8784db2a6bf9aa90c04768743aee6eaefae517feb9f7066d748cae894c1a2299 SHA512 7902aab160b5fd6e1bb1573777f9fab065ed33b0df19da2b5dad31ca962eaea93f9d46e57efca2d76df26c55b48e0578fddf4136e36ed565d8a2b5258dc34afd
+DIST logwatch-7.10.tar.gz 511766 BLAKE2B 66d7cb09f4c73ca55a3bad9eb2e9a46eabdc0da444e5361ddc10e7bee28de2e58f2c10530f75d40b2689d33624d612f439171b995e9f21a7e48bf211db1f2bd2 SHA512 838bcc7a3b12eb31450a20195fe2ca4ab238500051bb2f50bd1775272fefa412e0a2473c0294a5495ef594fa530b00dac0dc6d18b93e124f36614686502e55cb
DIST logwatch-7.9.tar.gz 501086 BLAKE2B ebfc65c88036244840fe4fbf42c0bea668cac3063771f0042827a2f583d654403b75bdfa428f50a7fdac5f0098ec08ef5a27006db7f7576b361653594462d607 SHA512 d091fbbeb0cac4b661fb066118fd384dbdeabe137c699ea6892d53567a45978c0742b1be9cf2f8b8c2e522314351ee6c2e3710ac2e61bbf1a3c8d63f78a3646f
+EBUILD logwatch-7.10.ebuild 2492 BLAKE2B 3bda1be9c5a389049e6a2def599c910bf717f9a1e5670f59a04dbe2f815e06ae3afb23c56c5b8dae4a22ec265d4eab95fa2800dee7484a3afc72fedec499fc2d SHA512 75c0acd6d409d20cb1e8f8a91be7c276a13b2d5c98cc8db33d0c5500585db56621c2f0c8c8212b35e36db6c029b6db836c2703d0c8061f10c069ed397d29bb8e
EBUILD logwatch-7.9.ebuild 2484 BLAKE2B 8a30d602bda388e99701353d6765c9340251b325a813ff927cf6a6b34e4a2fde31c3c03a1f223948838b0d8e87472272ba7fa93b150af677b8ad2036ee70588b SHA512 4334bde2e9f7a4640b4ce27392badaf22ba1383d267f1835b32879519fd65ee0fbc2eac138d709a078a9d8d09b4a97455a3cb823dd8cd83fdd3edce35b744df3
EBUILD logwatch-9999.ebuild 2492 BLAKE2B 88119a119c08dd47428628e1744fdec2fdc4ff429bd5d3e81da52b26c65671e5d34af83b73a374b396d576b6f648afe072f6fc03f160e5504ea2c6cd4d867eee SHA512 eed8787ba2c1f079d5d34fa5400e21991031438aee9bdde80e07f9d31dd2c49163d2d761df0e0574c645158476d4bca8d44ff2861bc85dd348667cce28011721
MISC metadata.xml 329 BLAKE2B ae6bfb6282dd2f5ddc01959eb57e894cc12a69de5fea771439d9b2a95110754fd7c35db97ee238865cfb81333800dcdcfb42654d12572e16cde12c7212a505c5 SHA512 a523f269535d7e0272f2d66b903319197f52477dbf40b32729eff93b5788f9c8b8756a4750128f894b4ab0d05b9effbac5d350e5ae2ab68474ef4fa39022710a
diff --git a/sys-apps/logwatch/logwatch-7.10.ebuild b/sys-apps/logwatch/logwatch-7.10.ebuild
new file mode 100644
index 000000000000..b83d3ef67595
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="selinux"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/HTML-Parser
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+ selinux? ( sec-policy/selinux-logwatch )
+"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}