summaryrefslogtreecommitdiff
path: root/sys-apps/lcdtest/lcdtest-1.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/lcdtest/lcdtest-1.18.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/lcdtest/lcdtest-1.18.ebuild')
-rw-r--r--sys-apps/lcdtest/lcdtest-1.18.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/lcdtest/lcdtest-1.18.ebuild b/sys-apps/lcdtest/lcdtest-1.18.ebuild
new file mode 100644
index 000000000000..4b5876b1bab5
--- /dev/null
+++ b/sys-apps/lcdtest/lcdtest-1.18.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit scons-utils eutils toolchain-funcs gnome2-utils
+
+DESCRIPTION="Displays test patterns to spot dead/hot pixels on LCD screens"
+HOMEPAGE="http://www.brouhaha.com/~eric/software/lcdtest/"
+SRC_URI="http://www.brouhaha.com/~eric/software/lcdtest/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-libs/libsdl-1.2.7-r2[X,video]
+ >=media-libs/sdl-image-1.2.3-r1
+ >=media-libs/sdl-ttf-2.0.9
+"
+RDEPEND="${DEPEND}
+ media-fonts/liberation-fonts
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-build-system.patch"
+ epatch_user
+ sed -i -e \
+ "s|/usr/share/fonts/liberation/|/usr/share/fonts/liberation-fonts/|" \
+ src/lcdtest.c || die
+}
+
+src_configure() {
+ tc-export CC
+ myesconsargs=(
+ --prefix="${EPREFIX}/usr"
+ )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ escons --buildroot="${D}" install
+ dodoc README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}