summaryrefslogtreecommitdiff
path: root/sys-apps/kbd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /sys-apps/kbd
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest2
-rw-r--r--sys-apps/kbd/kbd-2.6.0.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 1ce2b2c09872..83485380a3e1 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1,4 +1,6 @@
DIST kbd-2.5.1.tar.xz 1491952 BLAKE2B aab4c3d78c28709bf562b54fe94c0533d5c33185e183bf3eb944f89147b250d9df9b30b64a06eb4742feafe8c05a6aa491a7f007b4d6d9077bc19a4628ba05ae SHA512 74855f486aff5fc2f93a6cb29460a590c94eac653b001574e1b4eb1300ea99dfed9222f9e5d1d3a05a112a6880591d5c44ed6e76b8a64edf744ecb0892f562d0
+DIST kbd-2.6.0.tar.xz 1590196 BLAKE2B 9894bab607694cc60cece959573b8f13f687d47b4346fa84e57bffd2c062a5ac2830f9a6766aca70d2242f63f486c898fe5d777fc01dfabe85d004b1f29d364a SHA512 4b8cec06ea2143a285bedb95cb66c313ebac79dc3c64956f969f389186609bc1a066dbf32d6ae308e18947dcbe2f6f684f6c69d4210b40d449735e5704707b27
EBUILD kbd-2.5.1.ebuild 2027 BLAKE2B 66c55f1296812b9a197460a8a90bf237def618d6fc9d00ad6e26ff543b1918c7274aae2627c836925099ed37645bf6fa5c05ebfc392077b265b46f0d31d0b1c9 SHA512 9734368dac398812fee31c31a29f6ec8b4819181a8a0a711ceadb64c825aaf515aa35d767185bf9379e5287facda5f53c923ef64aeb3f45ea054b5a5c97f2dd2
+EBUILD kbd-2.6.0.ebuild 2035 BLAKE2B 3e9eba8e9dd337204ae968ef190ef6c6a24314f2d0c1db8f118571e020f978863a56e3307675f10ac8c059918c2cc507230d0df7f7f8aa073419289d4bdd8c84 SHA512 9df260874f514c49d5a8d3c9a763118ee9f880b1cbc2631b1c5c039429ad5a6a61ce18c3d593ebb0d0b884fc2fc5653762ca1e4155fe3c55b771bd3cd50dd3aa
EBUILD kbd-9999.ebuild 2035 BLAKE2B 3e9eba8e9dd337204ae968ef190ef6c6a24314f2d0c1db8f118571e020f978863a56e3307675f10ac8c059918c2cc507230d0df7f7f8aa073419289d4bdd8c84 SHA512 9df260874f514c49d5a8d3c9a763118ee9f880b1cbc2631b1c5c039429ad5a6a61ce18c3d593ebb0d0b884fc2fc5653762ca1e4155fe3c55b771bd3cd50dd3aa
MISC metadata.xml 335 BLAKE2B 3b00a31428edc76e9a758c347107ad15e2f91a440a49e5167878555eda6dad176f8936ca22acbbecb5ff4827d8605b28db53ca990284b4e18c536a04d46616ed SHA512 86a6b134e0403abf5c22e868e2013a2051f504401d5ff8aa1ad682638d866ab8d837470ed87434286b77933483d7675646f382b15aed19772b2fff17258fc0f7
diff --git a/sys-apps/kbd/kbd-2.6.0.ebuild b/sys-apps/kbd/kbd-2.6.0.ebuild
new file mode 100644
index 000000000000..47ef0e794f21
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.6.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="https://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+RESTRICT="!test? ( test )"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+RDEPEND="
+ app-alternatives/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ default
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
+
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc docs/doc/*.html
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}