summaryrefslogtreecommitdiff
path: root/sys-apps/kbd/kbd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sys-apps/kbd/kbd-9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sys-apps/kbd/kbd-9999.ebuild')
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index faad110fb541..32395a108a73 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -11,8 +11,13 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/legionus/kbd.git"
EGIT_BRANCH="master"
else
- SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
fi
DESCRIPTION="Keyboard and console utilities"
@@ -53,7 +58,7 @@ src_unpack() {
src_prepare() {
default
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == "9999" ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
eautoreconf
fi
}