summaryrefslogtreecommitdiff
path: root/sys-apps/iproute2/iproute2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /sys-apps/iproute2/iproute2-9999.ebuild
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'sys-apps/iproute2/iproute2-9999.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index c6720ff8aed3..f9527624933e 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,12 +18,11 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="atm berkdb caps elf +iptables ipv6 minimal selinux"
+IUSE="atm caps berkdb elf +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
!net-misc/arpd
- dev-libs/libbsd
!minimal? ( net-libs/libmnl )
caps? ( sys-libs/libcap )
elf? ( virtual/libelf )
@@ -40,19 +39,18 @@ DEPEND="
>=sys-devel/bison-2.4
sys-devel/flex
>=sys-kernel/linux-headers-3.16
- virtual/pkgconfig
elibc_glibc? ( >=sys-libs/glibc-2.7 )
"
PATCHES=(
"${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- "${FILESDIR}"/${PN}-4.20.0-configure-nomagic.patch # bug 643722
+ "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
)
src_prepare() {
if ! use ipv6 ; then
PATCHES+=(
- "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch #326849
+ "${FILESDIR}"/${PN}-4.11.0-no-ipv6.patch #326849
)
fi
@@ -63,6 +61,7 @@ src_prepare() {
-e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ -e "/^WFLAGS/s:-Werror::" \
-e "/^DBM_INCLUDE/s:=.*:=${T}:" \
Makefile || die
@@ -73,12 +72,10 @@ src_prepare() {
man/man8/ip-netns.8 || die
# build against system headers
- rm -r include/netinet || die #include/linux include/ip{,6}tables{,_common}.h include/libiptc
+ rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
- if use minimal ; then
- sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile || die
- fi
+ use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile
}
src_configure() {
@@ -149,7 +146,7 @@ src_install() {
sed -i '/linux\/netconf.h/d' "${ED%/}"/usr/include/libnetlink.h || die
if use berkdb ; then
- keepdir /var/lib/arpd
+ dodir /var/lib/arpd
# bug 47482, arpd doesn't need to be in /sbin
dodir /usr/bin
mv "${ED%/}"/sbin/arpd "${ED%/}"/usr/bin/ || die