summaryrefslogtreecommitdiff
path: root/sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch')
-rw-r--r--sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch b/sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch
new file mode 100644
index 000000000000..31733e99f72c
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch
@@ -0,0 +1,38 @@
+--- iproute2-4.20.0/ip/ipmonitor.c
++++ iproute2-4.20.0/ip/ipmonitor.c
+@@ -118,7 +118,6 @@
+
+ case RTM_NEWPREFIX:
+ print_headers(fp, "[PREFIX]", ctrl);
+- print_prefix(n, arg);
+ return 0;
+
+ case RTM_NEWRULE:
+--- iproute2-4.20.0/ip/iptunnel.c
++++ iproute2-4.20.0/ip/iptunnel.c
+@@ -549,13 +549,6 @@
+ break;
+ case AF_INET:
+ break;
+- /*
+- * This is silly enough but we have no easy way to make it
+- * protocol-independent because of unarranged structure between
+- * IPv4 and IPv6.
+- */
+- case AF_INET6:
+- return do_ip6tunnel(argc, argv);
+ default:
+ fprintf(stderr, "Unsupported protocol family: %d\n", preferred_family);
+ exit(-1);
+--- iproute2-4.20.0/ip/Makefile
++++ iproute2-4.20.0/ip/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ IPOBJ=ip.o ipaddress.o ipaddrlabel.o iproute.o iprule.o ipnetns.o \
+- rtm_map.o iptunnel.o ip6tunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
+- ipmaddr.o ipmonitor.o ipmroute.o ipprefix.o iptuntap.o iptoken.o \
++ rtm_map.o iptunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
++ ipmaddr.o ipmonitor.o ipmroute.o iptuntap.o iptoken.o \
+ ipxfrm.o xfrm_state.o xfrm_policy.o xfrm_monitor.o iplink_dummy.o \
+ iplink_ifb.o iplink_nlmon.o iplink_team.o iplink_vcan.o iplink_vxcan.o \
+ iplink_vlan.o link_veth.o link_gre.o iplink_can.o iplink_xdp.o \