summaryrefslogtreecommitdiff
path: root/sys-apps/ipmicfg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /sys-apps/ipmicfg
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'sys-apps/ipmicfg')
-rw-r--r--sys-apps/ipmicfg/Manifest3
-rw-r--r--sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild60
-rw-r--r--sys-apps/ipmicfg/metadata.xml12
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/ipmicfg/Manifest b/sys-apps/ipmicfg/Manifest
new file mode 100644
index 000000000000..541dc302238a
--- /dev/null
+++ b/sys-apps/ipmicfg/Manifest
@@ -0,0 +1,3 @@
+DIST IPMICFG_1.27.1_build.170901.zip 1667230 BLAKE2B 6411f735fed2e66f8dc012c480e6f9a4c2c9223643074514ca6fbb0db62df06fd78714c4a95ce92edc22a4473734a1d41a6c3bdb61268c73a628f08e7dc87c0e SHA512 9ed01a8a1eae7a7e41fafdbb3b666e7760057c960b65da547f0cf197b30b1a535fa2fe8357e13e6ccda0e0dd4474170b43ca3bc89f55c2de5df0160adde9377e
+EBUILD ipmicfg-1.27.1.170901.ebuild 1425 BLAKE2B 130cfa8b7cf23f2316fd45f174bef028c7c6e5c3b3344b4651b93339258cd4c1d28cc2ca335ac649a995c65b049881bcaf131f69d8fab2fcbf493d0c4f251a4e SHA512 572e8b141d38c2421e020b0453d8e859182c9d9a37711ff7292aab3f837e9b08e559b814050c1b3b48e78999460a70b78602535d6aaade957564f296f1e0b7a0
+MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
diff --git a/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild b/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild
new file mode 100644
index 000000000000..ce0d6c434345
--- /dev/null
+++ b/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN^^}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="An in-band utility for configuring Supermicro IPMI devices"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="ftp://ftp.supermicro.com/utility/${MY_PN}/${MY_PN}_${MY_PV}_build.${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RDEPEND="sys-libs/glibc"
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_build.${MY_DATE}"
+
+QA_PREBUILT="opt/ipmicfg/IPMICFG-Linux.x86 opt/ipmicfg/IPMICFG-Linux.x86_64"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=IPMI"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ # Choose ARCH
+ if use amd64; then
+ local my_arch_binary="x86_64"
+ local my_arch_folder="64bit"
+ else
+ local my_arch_binary="x86"
+ local my_arch_folder="32bit"
+ fi
+
+ # Install files
+ insinto "/opt/ipmicfg"
+ doins "Linux/${my_arch_folder}"/*.dat
+
+ # Install binary
+ exeinto "/opt/ipmicfg"
+ doexe "Linux/${my_arch_folder}/IPMICFG-Linux.${my_arch_binary}"
+
+ # Install symlink
+ dodir "/opt/bin"
+ dosym "../ipmicfg/IPMICFG-Linux.${my_arch_binary}" "/opt/bin/ipmicfg"
+
+ # Install docs
+ local DOCS=( "IPMICFG_UserGuide.pdf" "ReleaseNotes.txt" )
+ einstalldocs
+}
diff --git a/sys-apps/ipmicfg/metadata.xml b/sys-apps/ipmicfg/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/sys-apps/ipmicfg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>