summaryrefslogtreecommitdiff
path: root/sys-apps/iotools/iotools-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sys-apps/iotools/iotools-1.5.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sys-apps/iotools/iotools-1.5.ebuild')
-rw-r--r--sys-apps/iotools/iotools-1.5.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-apps/iotools/iotools-1.5.ebuild b/sys-apps/iotools/iotools-1.5.ebuild
index d508f1263e1a..01ade1d402f3 100644
--- a/sys-apps/iotools/iotools-1.5.ebuild
+++ b/sys-apps/iotools/iotools-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Simple commands to access hardware device registers"
HOMEPAGE="https://code.google.com/p/iotools/"
@@ -14,9 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc x86"
IUSE="static make-symlinks"
-src_prepare() {
- sed -i 's:-Werror::' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_compile() {
emake \
@@ -32,7 +30,7 @@ src_install() {
# when cross-compiling will likely fail.
local known_cmds="and btr bts busy_loop cmos_read cmos_write cpu_list mem_dump mem_read16 mem_read32 mem_read64 mem_read8 mem_write16 mem_write32 mem_write64 mem_write8 mmio_dump mmio_read16 mmio_read32 mmio_read64 mmio_read8 mmio_write16 mmio_write32 mmio_write64 mmio_write8 not or pci_list pci_read16 pci_read32 pci_read8 pci_write16 pci_write32 pci_write8 runon shl shr smbus_quick smbus_read16 smbus_read8 smbus_readblock smbus_receive_byte smbus_send_byte smbus_write16 smbus_write8 smbus_writeblock xor"
case ${ARCH} in
- amd64|x86) known_cmds+=" cpuid io_read16 io_read32 io_read8 io_write16 io_write32 io_write8 rdmsr rdtsc wrmsr";;
+ amd64|x86) known_cmds+=" cpuid io_read16 io_read32 io_read8 io_write16 io_write32 io_write8 rdmsr rdtsc wrmsr";;
esac
if ! tc-is-cross-compiler ; then
local sorted_cmds=$(echo $(printf '%s\n' ${known_cmds} | LC_ALL=C sort))