summaryrefslogtreecommitdiff
path: root/sys-apps/init-system-helpers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /sys-apps/init-system-helpers
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'sys-apps/init-system-helpers')
-rw-r--r--sys-apps/init-system-helpers/Manifest3
-rw-r--r--sys-apps/init-system-helpers/files/revert-openrc-management.patch32
-rw-r--r--sys-apps/init-system-helpers/init-system-helpers-1.49-r1.ebuild (renamed from sys-apps/init-system-helpers/init-system-helpers-1.49.ebuild)4
3 files changed, 37 insertions, 2 deletions
diff --git a/sys-apps/init-system-helpers/Manifest b/sys-apps/init-system-helpers/Manifest
index 9f44a1a3f01a..bc47bc846dfa 100644
--- a/sys-apps/init-system-helpers/Manifest
+++ b/sys-apps/init-system-helpers/Manifest
@@ -1,3 +1,4 @@
+AUX revert-openrc-management.patch 798 BLAKE2B 1e04e2f9c361eb0c125e5b23d0b18c58198ad968fec5965f43e6a5e8b8201d29c7ad2c05431d7107d99acc75ab397cfd90121f7f0618f9bb440a8d6687039c20 SHA512 8d8cc8886b5d731b7538425e6be10b4fa8d0c8b8eb946a64e885a0f9dc19c02d596a803716a8a6d681fb9e408650993b9c81ef23d2d0ab53485d65b15863ace7
DIST init-system-helpers_1.49.tar.xz 42660 BLAKE2B 548711283b04e3df13e9287154e2648b99ac80c2cdc71a428b4496220cd7c319f8f7afccb1e611c07b9d801837ef8799a3295a0490aa62812d47b728ba5ddba9 SHA512 bd612207e51e18a44f9c90e1e5b069ab39e06c776b8a0d6c9ecb367890d4a44ff02b3028418ac10a688782745331f39bb9299ba836f333b712e6fdd7ddc8da16
-EBUILD init-system-helpers-1.49.ebuild 815 BLAKE2B 306abc82f3861a023806af2ecd3405cad3cc91583d4c4228d82011ed18a26646006972eee6a007b1e948abfad4957021abec0824758fb5ae3f51517504cdc5cd SHA512 85dab1d5da36a44623e5ab695d9d51ea060bafe8096b0c0ccfb4139b3717dc61f1660d0545fb6515b3cd11a059ed627fc06e2e69741f2e16621230c06e067900
+EBUILD init-system-helpers-1.49-r1.ebuild 873 BLAKE2B 63f0c2667c7d0b33933441306679e91ef0a73a954bdf5745aba5c2fb595b005200712dbf5ae4f839be4c510dd147a056c7be12e4393238729ccb1a9242ef2c9c SHA512 d871bd419612fadb89af12c02e7a379fcb569f1bc0e219a165090ec8bd1499adb934b6007e3d063da4440371176012aead4220a521a2b05620db479c73c8086e
MISC metadata.xml 251 BLAKE2B 4460dac0ad38483c59c081f8ac585d0fe55e4085cc41c667ca1a17fee091a7acffb39680b254e60145fc8d78aec9acc80322319dfb24aa9820b468fcece8e27b SHA512 307528de6c03f6a97b95e189cb88eab281d278ad8b09833cf8c6924fc88fc38b17179a47fc463dd809e5f077b3b2bc74640e28816e50ab712b1989364b9d3bf0
diff --git a/sys-apps/init-system-helpers/files/revert-openrc-management.patch b/sys-apps/init-system-helpers/files/revert-openrc-management.patch
new file mode 100644
index 000000000000..49b4916fab31
--- /dev/null
+++ b/sys-apps/init-system-helpers/files/revert-openrc-management.patch
@@ -0,0 +1,32 @@
+--- a/script/service
++++ b/script/service
+@@ -159,23 +160,6 @@ run_via_sysvinit() {
+ fi
+ }
+
+-update_openrc_started_symlinks() {
+- # maintain the symlinks of /run/openrc/started so that
+- # rc-status works with the service command as well
+- if [ -d /run/openrc/started ] ; then
+- case "${ACTION}" in
+- start)
+- if [ ! -h /run/openrc/started/$SERVICE ] ; then
+- ln -s $SERVICEDIR/$SERVICE /run/openrc/started/$SERVICE || true
+- fi
+- ;;
+- stop)
+- rm /run/openrc/started/$SERVICE || true
+- ;;
+- esac
+- fi
+-}
+-
+ # When this machine is running systemd, standard service calls are turned into
+ # systemctl calls.
+ if [ -n "$is_systemd" ]
+@@ -210,5 +228,4 @@ then
+ esac
+ fi
+
+-update_openrc_started_symlinks
+ run_via_sysvinit
diff --git a/sys-apps/init-system-helpers/init-system-helpers-1.49.ebuild b/sys-apps/init-system-helpers/init-system-helpers-1.49-r1.ebuild
index 5d7222aa8dbd..97888bcce019 100644
--- a/sys-apps/init-system-helpers/init-system-helpers-1.49.ebuild
+++ b/sys-apps/init-system-helpers/init-system-helpers-1.49-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,8 @@ IUSE=""
DEPEND=""
RDEPEND="!<sys-apps/openrc-0.33"
+PATCHES=( "${FILESDIR}/revert-openrc-management.patch" )
+
src_install() {
# We only care about 'service' script/manpage:
exeinto /sbin/