summaryrefslogtreecommitdiff
path: root/sys-apps/i2c-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /sys-apps/i2c-tools
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest2
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index 3a169c81cda1..7a77dfbb9cc9 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,4 +1,6 @@
AUX i2c-tools-3.1.1-python-3.patch 3348 BLAKE2B 4fbe75455e4370da6c61c786cd0eaef94039b24d9de33ecc1ac6333f5776d61d8638493f7b7218bd15e36301cfeed840217050ed37edf3825017cdbf9b7b3d25 SHA512 0f264e49237af0318c868deac39bdd7c2b718c39317c2e47b15ad7d421530dc165f38b5995ca45bcfd65074ab51022d88ced6f2d589e30ebbab1702cf964f8da
DIST i2c-tools-3.1.1.tar.bz2 71789 BLAKE2B 0a7a3db6a3b396cfb8d5e58d8c83cae4e52239786502c6552d971350f7fc05a1ce9d7d89e9cdb154a21ac15bdf34aa0dec9501ea45317ec9c5d9fc211780bbf1 SHA512 b91f89b803e5558d49ce63f42f6542438f4f47927e4ce420cd9df989cab14a5c55d971befed73e8f793b0cf4aa41936c0ef519e5a407dceb2c08964461e803c5
+DIST i2c-tools-4.0.tar.xz 79972 BLAKE2B 982e4139ed0e2111f9e082d0690fcc0f86f97a433e292e9464b41991f14a1f90147a3612172bad6880f0df6896612e1dea0ae7bf6f459758b2cff45fb35a5dc7 SHA512 ddf86c357c101388193581bc40285089e6ab5e8d870f8aa5d594acc7ecb8596fbd30501e147b88bdea0200b1be88bc0a374356c188d1bcb067bf8e254e3dc51e
EBUILD i2c-tools-3.1.1-r1.ebuild 1431 BLAKE2B 9e345a8bcc8122c6e5dc1dc08ce5e3278c682d35725d03ed92d1ca5650f92e6d24e9fc7b8419271f155ca440b538838969a3ed7b038cbd9d6616f1ab736b1343 SHA512 03b8a80f90970877019cc27d519e535fb7478d636603b937a63f375b3c7ed8264bf975bc3640541afbe02ca7f0de7e226940f6a0f6ab4a7f9d54f2fc02efc564
+EBUILD i2c-tools-4.0.ebuild 1400 BLAKE2B 3e8316aec0396172e0b3626f888fb4789eb36916592f085fb23148d893efdea13b2d82bd28ba0682390718c7a17e3ca2d1a16cbcb89e0118602a5b4e2e61581c SHA512 9cc0e3bf449c75a7502e384337912390cb66af15bb1ee51b64a76deffd7fa5b596c040eca9d6c88275e961a2862760d8531ecc268c6174ba082ad3646042da9d
MISC metadata.xml 214 BLAKE2B d6d548e131d54a9e13f05d269df0bf13b142967950b365aa52a37bec3a03ed97774f1ec27bf59d54457cd1903475f4f84c144256f5a96643a0bbd1c20714930a SHA512 ae2a716aa849a3e9bd264007acc830ed4ee3c3acd1fc76ed1a60c683e248bded6aeefa174f04d70f0a7705c57bbd1e1ca44fd975f140c12de415381702d8df43
diff --git a/sys-apps/i2c-tools/i2c-tools-4.0.ebuild b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
new file mode 100644
index 000000000000..d5f248f7c280
--- /dev/null
+++ b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+DISTUTILS_OPTIONAL="1"
+
+inherit flag-o-matic multilib toolchain-funcs distutils-r1
+
+DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
+HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
+SRC_URI="${HOMEPAGE}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="!<sys-apps/lm_sensors-3
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ emake all-lib CC=$(tc-getCC) # parallel make
+ emake CC=$(tc-getCC)
+ emake -C eepromer CC=$(tc-getCC)
+ if use python ; then
+ cd py-smbus || die
+ append-cppflags -I../include
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ emake install-lib install libdir="${D}"/usr/$(get_libdir) prefix="${D}"/usr
+ dosbin eepromer/eeprom{,er}
+ rm -rf "${D}"/usr/include # part of linux-headers
+ dodoc CHANGES README
+ local d
+ for d in eeprom eepromer ; do
+ docinto ${d}
+ dodoc ${d}/README*
+ done
+
+ if use python ; then
+ cd py-smbus || die
+ docinto py-smbus
+ dodoc README*
+ distutils-r1_src_install
+ fi
+}