summaryrefslogtreecommitdiff
path: root/sys-apps/hwinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
commit83b5cde41ddb8fd20de4536dd68eb08da42d013e (patch)
tree6a993cfe0eb5a8024c508e9f6a6de02538f7c52e /sys-apps/hwinfo
parent9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (diff)
gentoo auto-resync : 17:07:2022 - 20:32:17
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/Manifest2
-rw-r--r--sys-apps/hwinfo/hwinfo-21.82.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index b1a9d096db1a..d5a282b7cab0 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,5 +1,7 @@
DIST hwinfo-21.80-1.1.src.rpm 968192 BLAKE2B a11a1060137ff89504963c01c4129dcac93e8eea9747ea20272763f648068e8b4fb3f1c31ae761664b1b1ffedf32971b3b27804f125473f0367cc6eed03751bf SHA512 7bf64d9ee6b2381c43ffb22dc5623c8a8ed05c26b4e154c3093a9cb255779a1d482c18cd085b272ce619249743f1c43989337bed142685b4d6c634f4551893ee
DIST hwinfo-21.81-1.3.src.rpm 967951 BLAKE2B af6c390cd327ac2683f6b92a7847c5a0dc99e7553e35b7a5fd07db0a7f60c671a303e85061e1656474792b921e0d1b8ad18591f22a5da557879743d91151509a SHA512 eef89b5c8c029f606d66eb1740c4d046baaf490fc39d42d0137d1c4c5b248b0ddbe34b1532dbcef10f408677f173cfeb11d4c3e801a6a90280e1a6babc245674
+DIST hwinfo-21.82-1.1.src.rpm 968922 BLAKE2B 5a491e7ca7125b40205dfa0e28350124f3deab6438424289ec44588940c47ddd341c9a7705edd3b9678b80050e26acdad1e9ea4aa7bc47e1af670ae020bfec51 SHA512 7221430e67bd76016d535db823e5e66034001c24e49de656365b421ef528bdcdf94ad82399f6a5916e55dc0b9f2dc1873a0e9ae2813025b746999bb2c5bd02df
EBUILD hwinfo-21.80.ebuild 1561 BLAKE2B f66110bb40f16efaeade743b03ddc26b72cd7b875c4ecf6c4599f1729c0feaab83a3b3f24867630c46c38ccac6ac6010eacc0b8b655f1e3d03af8e4679330ce9 SHA512 b455efce4294dbbcba410c675df5f0c34c4e97b9fa065953db481faa060d51348619f3f6c1030e4eae8336749e717034a73501ecb347f19f03204d2058a133aa
EBUILD hwinfo-21.81.ebuild 1564 BLAKE2B d7a479b2084764650c4d4aeb3532d05a28647f6c5003297faac2a61ebd03b4d9d016140d54d5c5146b0c280b2b15059ebb8869398c636716fd53ad2045d25878 SHA512 1ab47b4a72a20408b2395e795e5965884c4ce2f539b14087f5524804f5ac879c73300f9b1e6e1c155e5b960b53b5ce6c5a10fc742faf25b786c21ffa5401a71d
+EBUILD hwinfo-21.82.ebuild 1564 BLAKE2B 4be0e61fe6a66381f3a9d54ded59b0be601ed883c6e6d90f0556196c5e21fceeeb8594be8a04d28279795fb089fb695a4ca65347e184312c131962b434077a4f SHA512 11e7f26927dd6bbf4d655b12c427bdedbbe1858c0006ea9c37346e2c9ccdcbbbd5d982ffe23883c2a1b19ed898b20bbca6ec40142aeacfefafd406a7bccdb380
MISC metadata.xml 335 BLAKE2B 038b3d0d2c3215e9c141823f3578880ecb43da74b991cce36793a6af5b3549603ad1fa95c1bbe477126c3b84f6493099400d8914d94cdbe1c557b0166c0ca43b SHA512 e24489f0c20cc1cd356f7059c4a2a8d02b2f39fcb43df0d685977ce6e1593c134420daf6d940f96f08fd0d19026618d89946e6ff0a24f449be5d5c8910b10581
diff --git a/sys-apps/hwinfo/hwinfo-21.82.ebuild b/sys-apps/hwinfo/hwinfo-21.82.ebuild
new file mode 100644
index 000000000000..a54748333293
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-21.82.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}