summaryrefslogtreecommitdiff
path: root/sys-apps/hw-probe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-apps/hw-probe
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest4
-rw-r--r--sys-apps/hw-probe/files/README.gentoo7
-rw-r--r--sys-apps/hw-probe/hw-probe-1.5.ebuild62
-rw-r--r--sys-apps/hw-probe/metadata.xml18
4 files changed, 91 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
new file mode 100644
index 000000000000..fa7338cb4b28
--- /dev/null
+++ b/sys-apps/hw-probe/Manifest
@@ -0,0 +1,4 @@
+AUX README.gentoo 301 BLAKE2B c352d3f7e0038ef8f71f6e95376e91513c45914f7d4c31ec0390a0e9745360d7114b3c4e2743d2cb5872241073a3a4087a3240f2f0ef89e3203b5500520d7eb2 SHA512 a20a1a910a7f852844bfd8f03e824e74760c49c5bf7171f1dbfb16976805179ed79a3ae892ba70e99bcd93182bb1d83f491b9a5f7b64e94478172a424c00350e
+DIST hw-probe-1.5.tar.gz 113996 BLAKE2B 59f6fc27e2cbb99a4b7dd9428e32a93dce2ffcc1133e82539b8836a694e6c5634fe2e172732675acf0d83504907a750c63f138d6dec236039eb7c805010a8383 SHA512 80dd2484bd317ac1e86d7f434626f288648aebf110a4bf81c0c05548abcb19d990119c1690fcb5796384a6c32fd5c1e827698a31165bfc41ef6df9fc7fdd368d
+EBUILD hw-probe-1.5.ebuild 2210 BLAKE2B 8ff9c34cfbc97dedca047482c09dca307dec3656aa2e571b79b188e22524df50328736842dc6cfc871c36fd7618add95d6e95e5efa6bd5c906d492b15b996d54 SHA512 3590836c0a90a7d5684ae2b888ddf45ccdeee702fcbfdb2ef842a8ac4bbdd9a0f3458ccefda8ccbf98b9777dc67271c346d290c1157fca6d98a901688b696221
+MISC metadata.xml 646 BLAKE2B 1cc93bfb0e3544c4c746e80ff21675fa22d3103e14a040ffedfcfd24e73d8d968decc318e4523a03815e85de4ef85926ac20d4dfdf7cde5a3445ca29f11f6de7 SHA512 2ea8a211186b71ebc008c9999225edef063c8c8e0317d6e4c6149cc6ec6281a84065bef3dc93b4308f8567860fb75c19287aa91b5ab41e6a68229fcbf1c5a474
diff --git a/sys-apps/hw-probe/files/README.gentoo b/sys-apps/hw-probe/files/README.gentoo
new file mode 100644
index 000000000000..521f7f4aaaaf
--- /dev/null
+++ b/sys-apps/hw-probe/files/README.gentoo
@@ -0,0 +1,7 @@
+Please keep in mind, that all results are being uploaded
+by default directly to the Linux Hardware Database
+and can be read by everyone in public.
+
+In order to identify unique computers and hard drives,
+a 32-byte prefix of a salted SHA512 hash from
+MAC addresses and serial numbers is being uploaded.
diff --git a/sys-apps/hw-probe/hw-probe-1.5.ebuild b/sys-apps/hw-probe/hw-probe-1.5.ebuild
new file mode 100644
index 000000000000..cd01ab71c9ca
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}
diff --git a/sys-apps/hw-probe/metadata.xml b/sys-apps/hw-probe/metadata.xml
new file mode 100644
index 000000000000..55a7ebd2ff02
--- /dev/null
+++ b/sys-apps/hw-probe/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Hardware Probe Tool is a tool to probe for hardware,
+ check it's operability and find drivers.
+ The probes are uploaded to the Linux hardware database.
+ See https://linux-hardware.org for more information.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/linuxhw/hw-probe/issues</bugs-to>
+ <remote-id type="github">linuxhw/hw-probe</remote-id>
+ </upstream>
+</pkgmetadata>